android
  #101  
Old 03-31-2010, 05:42 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,409
Default

Quote:
Originally Posted by nick_sub View Post
I wouldn't have bought the Clip if it wasn't for RB. It's a shame manufacturers don't support it because it would genuinely boost sales and provide us with better devices. However, I read on Wikipedia that Sansa are the first manufacturer to request Rockbox development on one of their devices - good for them.
You may want to hold off on the praise for Sansa for requesting/helping with Rockbox. Here's a link to the real story.

I've read several articles saying that Sansa was involved it the development of Rockbox on the Sansa. To Sandisk's credit I've never come across anything from them claiming any credit or even admitting any involvement in the e200 port. It just seems to be one of those stories that grows with each telling.

Quote:
Originally Posted by nick_sub View Post
Are there any confirmed brickings yet?
I've read too many reports from users saying that they have "bricked" their players. They all seemed to stem from people not understanding the extent of what a read only memory meant. Attempting create playlists on the player, save game scores, build a database or anything that required writing to the memory seemed to cause some really hard lockups in the earliest builds. People would then report that they had bricked their player. Just about all of them seem to have ben resolved with either a reset or letting the battery drain. Just read a report from yesterday on another site where a user said their his "bricked" Clip+ came back to life after the battery reached zero.

Across the last 1 1/2 years of using Rockbox I've discovered that if you follow the instructions in the manual and use code released on the Rockbox site it is damn difficult to actually brick (render beyond all usefulness) a player. Despite my most fumble fingered installs on 20+ players they all work today.
Reply With Quote

Advertisement [Remove Advertisement]

  #102  
Old 03-31-2010, 08:53 PM
Rockin Munki's Avatar
Rockin Munki Rockin Munki is offline
Junior Member
 
Join Date: Mar 2010
Location: England
Posts: 15
Default

Got my 8GB clip+ today, rockboxed it an hour later, used it all day and it only died once but 1 reset later and it was good again. It really is pretty impressive! However, with no write support it still is pretty useless to me, I sort my music by id3tags but it can't save the database (I really should have realised this before installing) so you cant browse by tags. I use the clip mostly for Audiobooks and Podcasts but this isn't practical on Rockbox atm as you cant save your place in a file (I did know this before installing but I wanted to try Rockbox anyway). The software is good but wont be much use(at least to me) until write support is implemented. Keep up the great work!
Reply With Quote

  #103  
Old 04-01-2010, 12:53 AM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Talking

Quote:
Originally Posted by JanDo View Post
Hello all!
I tested RB at my Sansa Clip+ 8GB.
And get playback time at flac 8level compression at 75% volume - about 14hours!
At same material at OF playback time only 7hours! Tested at RB r25376
Very interesting, I guess if we are careful we can always make better than OF, not always worse like on Clipv1.

Today I added support for dynamic CPU frequency so the CPU goes from 60MHz to 240MHz when it needs more power, instead of being always at 120MHz.

Can you make another test of playback time with a current build r25417 or more recent ?
Reply With Quote

  #104  
Old 04-01-2010, 02:42 AM
JanDo JanDo is offline
Junior Member
 
Join Date: Mar 2010
Posts: 6
Default

Quote:
Originally Posted by funman View Post
Can you make another test of playback time with a current build r25417 or more recent ?
Ok. I download build r25418. Results will be available here tomorrow.

UPD. Sorry i think no result tomorrow. Whith build r25418 RB start loading and crash(view initial screen whith RB logo and after lcd off, no response to button press).
info from rockbox-info.txt
Quote:
Target: sansaclipplus
Target id: 66
Target define: -DSANSA_CLIPPLUS
Memory: 8
CPU: arm
Manufacturer: as3525
Version: r25418-100401
Binary: rockbox.sansa
Binary size: 478928
Actual size: 478920
RAM usage: 736956
Features: crossfade:dircache:flash_storage:lcd_bitmap:lcd_fl ip:lcd_invertitchscreen:multivolume:quickscreen: radio:recording:recording_swcodec:recording_mic:rt c:swcodec:tagcache:tc_ramcache:charging:usb_power: large_plugin_buffer
gcc: arm-elf-gcc (GCC) 4.0.3
ld: GNU ar 2.16.1
Host gcc: gcc (Ubuntu 4.4.1-4ubuntu9) 4.4.1
Host system: Linux

Last edited by JanDo; 04-01-2010 at 03:27 AM.
Reply With Quote

  #105  
Old 04-01-2010, 03:25 AM
maporter1968's Avatar
maporter1968 maporter1968 is offline
Junior Member
 
Join Date: Mar 2010
Location: UK
Posts: 17
Default

Okay I've been running Rockbox all week on my Clip+ without any issues, updating through out the week, Yesterday I was running r25316; today I installed r25418 and nothing!

The dual boot screen loads then everything switches off, I then have to wait ten seconds and reboot into the Sansa OS to get the Clip+ back to life - Is anyone else having an issue?

Cheers

Mark
Reply With Quote

  #106  
Old 04-01-2010, 04:11 AM
solomonella solomonella is offline
Junior Member
 
Join Date: Mar 2010
Location: Pilipinas
Posts: 57
Default

^

i have the same issue with the latest build..boot screen then nothing..had to revert back to the previous working version..i hope this gets fixed soon
Reply With Quote

  #107  
Old 04-01-2010, 04:26 AM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

r25421 might fix this problem, but I have just had a panic when playing from µSD so there could have been more new problems with the last changes.
Reply With Quote

  #108  
Old 04-01-2010, 05:51 AM
maporter1968's Avatar
maporter1968 maporter1968 is offline
Junior Member
 
Join Date: Mar 2010
Location: UK
Posts: 17
Default

Well version r25422 fixes the boot problem right up until the point until you use a micro SD card. If you boot WITHOUT a micro SD card inserted then Rockbox will boot-up fine, the moment you insert a micro SD card Rockbox hangs at the start-up screen.

So one problem has been fixed, but it's still broken

I guess we'll have to wait for the next release.

Last edited by maporter1968; 04-01-2010 at 06:32 AM.
Reply With Quote

  #109  
Old 04-01-2010, 09:36 AM
maporter1968's Avatar
maporter1968 maporter1968 is offline
Junior Member
 
Join Date: Mar 2010
Location: UK
Posts: 17
Default

Oh well now I see that r25423 has been released, having wasted an hour this morning on r25422, I thought that with this new release (r25423) maybe things had been sorted.

Oh how wrong I was, don't get me wrong it boots up okay which is good. Doesn't hang at the start screen with a micro SD card inserted, which is even better..............

It's just a shame that none of the buttons on the front work !!!

Since today is April the 1st, I've come to the conclusion someone is extracting the urine; therefore I'm reverting back to the original Sansa firmware until at least the 2nd of April.

Smurf that Rockbox !!!!!

Last edited by maporter1968; 04-01-2010 at 09:47 AM.
Reply With Quote

  #110  
Old 04-01-2010, 09:37 AM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Whining and bold fonts won't make Funman find/fix the issues any quicker.
Reply With Quote

  #111  
Old 04-01-2010, 09:44 AM
maporter1968's Avatar
maporter1968 maporter1968 is offline
Junior Member
 
Join Date: Mar 2010
Location: UK
Posts: 17
Default

dfkt, that is very true, may I just point out that I meant them in jest, hope no one takes them seriously.
Reply With Quote

  #112  
Old 04-01-2010, 09:53 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Attached Images
File Type: jpg Capture.jpg (59.3 KB, 46 views)
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #113  
Old 04-01-2010, 10:19 AM
maporter1968's Avatar
maporter1968 maporter1968 is offline
Junior Member
 
Join Date: Mar 2010
Location: UK
Posts: 17
Default

Marvin the Martian, I guess you got my reference to Smurfs then - Sorry if you thought I was being childish.

however the best bit with reference to smurfs comes from today's Rockbox IRC log.

I quote:

"huh, someone hacked rockbox ?"

"There are 'smurf' everywhere !!!"
Reply With Quote

  #114  
Old 04-01-2010, 10:22 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by maporter1968 View Post
Marvin the Martian, I guess you got my reference to Smurfs then - Sorry if you thought I was being childish.

however the best bit with reference to smurfs comes from today's Rockbox IRC log.

I quote:

"huh, someone hacked rockbox ?"

"There are 'smurf' everywhere !!!"
Actually, I didn't get it......I saw a snip of the rockbox site on another forum. No worries though.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #115  
Old 04-02-2010, 05:40 AM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

Quote:
Originally Posted by maporter1968 View Post
It's just a shame that none of the buttons on the front work !!!

Smurf that Rockbox !!!!!
Smurf you too! Don't forget this is still unstable work and expect breakage.

My clip+ buttons work fine so I don't know what I can do about it, just try next builds and see if they work, or feel free to send me this Clip+ so I can reproduce the problem.

r25428 just ran 15h30 playing mp3 @192kbps, perhaps we can get even better than that (already beating the OF promised 15 hours)
Reply With Quote

  #116  
Old 04-02-2010, 06:52 AM
solomonella solomonella is offline
Junior Member
 
Join Date: Mar 2010
Location: Pilipinas
Posts: 57
Default

Quote:
Originally Posted by funman View Post
r25428 just ran 15h30 playing mp3 @192kbps, perhaps we can get even better than that (already beating the OF promised 15 hours)

wow!15 and a half hours of playtime!nice job man!keep up the good work funman and the team
Reply With Quote

  #117  
Old 04-02-2010, 07:37 AM
maporter1968's Avatar
maporter1968 maporter1968 is offline
Junior Member
 
Join Date: Mar 2010
Location: UK
Posts: 17
Default

r25435 is working perfectly on my Clip+ this morning.

Rockbox really does make a Sansa Clip+ rock, it's sounds so much better than the standard Sansa firmware. So much so that I'd sooner not listen to a Clip+ useless it's been Rockboxed.

I'd just like to say a big thank you to Funman and the team for all the hard work, great stuff guys.
Reply With Quote

  #118  
Old 04-02-2010, 07:42 AM
JanDo JanDo is offline
Junior Member
 
Join Date: Mar 2010
Posts: 6
Default

My 8GB Clip+ with RB r25423 - 17h 26m playing FLAC v8 before shut down.
75%vol(-13), Koss the Plug, w/o microSD, playing from internel memory. About 3min display working. (OF playing FLAC only 6h 55m)
Reply With Quote

  #119  
Old 04-02-2010, 08:11 AM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

@maporter1968

good to read that the buttons work after all, please tell if they stop working in a further build, so perhaps i can smurf what smurfed.

@JanDo

wow much longer than my runtime! although I think I had set the volume to 0dB, I suppose it sucks more juice from the battery
Reply With Quote

  #120  
Old 04-02-2010, 08:54 AM
maporter1968's Avatar
maporter1968 maporter1968 is offline
Junior Member
 
Join Date: Mar 2010
Location: UK
Posts: 17
Default

Quote:
Originally Posted by funman View Post
@maporter1968

good to read that the buttons work after all, please tell if they stop working in a further build, so perhaps i can smurf what smurfed.

@JanDo

wow much longer than my runtime! although I think I had set the volume to 0dB, I suppose it sucks more juice from the battery
Funman, One minor issue to report - Mine along with a couple of Head-Fier's Clip+'s all freeze when we try to access Micro SD card with r25435.

Regards

Mark
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:03 PM.