android
  #1  
Old 02-28-2010, 09:51 AM
blatob blatob is offline
Junior Member
 
Join Date: Feb 2010
Posts: 1
Default iaudio t2 display brightness problem

Three years ago I bought iaudio T2 palyer. So far it was working perfectly. Sound quality is great, battery life quite good, but a month ago I had the first problem with it.
When I tried to turn on the player after recharging the battery nothing happened. At first I thought that the player had died, but after inspecting it, I found out that it was working, but I could not see anything on the OLED display because the brightness of the display was too low. Somehow, the brightness setting was lowered to "1". I promptly set it back to brightest (10). But it is not as bright as it used to be. Previously I never had any problem with it even during the bright days and now I must strain to see it properly when I'm indoors, with main lights in the room turned off.
It's 2 GB version with 2.11 firmware.
To be honest, I have no idea if the OLED display has limited lifespan. I'm hoping that, perhaps, some of the forum members had similar problems or, at least, have heard something about it. Maybe the reset or instaling the new firmware would help, but I would like to know if this problem could be solved that way.
Reply With Quote

Advertisement [Remove Advertisement]

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:52 PM.