android
Go Back   abi>>forums > MP3 Players By Brand > SanDisk Sansa > Sansa Clip / Clip+ / Clip Zip

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-24-2010, 09:25 AM
DaX_Brian DaX_Brian is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Default My Sansa Clip screen just went black it wont play sound and it wont power on

My clip has always been squirrly idk if thats normal.
Squirrly as in certain songs just stop all sound, so then I would click next song and click play/pause power down then power on and it would work.
But suddenly this morning it just turned off I have had it for a couple months now and it hasn't just done that before with like 50% power left, I tired to turn it back on to no avail.

I have it plugged into my compu via the provided cable and it hasn't even lit up to recognize the connection.

What can I do?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 02-24-2010, 11:07 AM
Mikerman Mikerman is offline
Ultra Senior Member
 
Join Date: Dec 2007
Posts: 2,367
Default

Did you try a reset? Hold the on switch uppermost for 15-30 seconds.
Reply With Quote

  #3  
Old 02-24-2010, 05:29 PM
DaX_Brian DaX_Brian is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Default

Yes I did twice, however I just plugged it into my comp just as a last ditch effort and it powered on just as it should so I guess I don't need this any more.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:01 AM.