android
  #1  
Old 02-22-2010, 01:51 PM
tamalet tamalet is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Default Help: error in folders

Hi, I bought a Cowon S9 for my wife a few months ago. I have updated the firmware to version 2.51.
Since she doesn't care about tagging her music, she is used to access it from the Folders view.
She has been complaining that some folders do not appear so I had a look.

I realized that on the player there is a folder inside Music called S9 which takes me back to the root directory. The weird thing is that is does not appear on the computer when I connect the player to the USB.
After some testing I realized that the last folder that you see when it's connected to the USB does not show on the player's interface. Even worse, every song that is in a directory after this ghost S9 directory is mapped to another song.

Has anyone experience anything similar? Any idea how to solve it?

Oh, and I remembered another problem. Yesterday she was listening to some music and the player completely froze. We could not even switch it off. She told me that's not the first time that happens. We had to wait until the battery discharged completely to use it again. I found that someway she had copied a .exe into the folder with music she was listening too.
I understand that she is not supposed to do that. But the player could have given some error message, or just ignored that file. Completely freezing is not an option.

Anyway, I want to make clear that in general I am happy with the player. Better put up with some small problems than being locked up by a company.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 02-22-2010, 01:57 PM
Syndrome's Avatar
Syndrome Syndrome is offline
Redneck Moderator
 
Join Date: Dec 2007
Posts: 1,278
Default

Did you try the reset button when it was freezing? If I was you I would format the entire thing and start over. Put new firmware, and be sure to use MSC mode to add your music and then see how it acts after that.
Reply With Quote

  #3  
Old 02-22-2010, 01:58 PM
ultrauber's Avatar
ultrauber ultrauber is offline
Senior Member
 
Join Date: Jun 2009
Posts: 516
Default

Quote:
Originally Posted by tamalet View Post
Hi, I bought a Cowon S9 for my wife a few months ago. I have updated the firmware to version 2.51.
Since she doesn't care about tagging her music, she is used to access it from the Folders view.
She has been complaining that some folders do not appear so I had a look.

I realized that on the player there is a folder inside Music called S9 which takes me back to the root directory. The weird thing is that is does not appear on the computer when I connect the player to the USB.
After some testing I realized that the last folder that you see when it's connected to the USB does not show on the player's interface. Even worse, every song that is in a directory after this ghost S9 directory is mapped to another song.

Format the s9 (make sure everything is backed up) then go to settings, system, and change the usb mode to msc. Reload tunes.

Has anyone experience anything similar? Yes. Any idea how to solve it?

Oh, and I remembered another problem. Yesterday she was listening to some music and the player completely froze. We could not even switch it off. She told me that's not the first time that happens. We had to wait until the battery discharged completely to use it again. I found that someway she had copied a .exe into the folder with music she was listening too.
I understand that she is not supposed to do that. But the player could have given some error message, or just ignored that file. Completely freezing is not an option.

That's why there's a reset button. Next time, try pushing a paper clip into the hole on the back. Don't stab the mic.

Anyway, I want to make clear that in general I am happy with the player. Better put up with some small problems than being locked up by a company.
Welcome to ABI!
__________________
Cowon S9 32GB > HiFiMan RE0 (RIP) | Sansa Clip+ 16GB (Rockbox) > Soundmagic PL20
If you have problems, try MSC mode, then google.com
Reply With Quote

  #4  
Old 02-22-2010, 01:58 PM
ultrauber's Avatar
ultrauber ultrauber is offline
Senior Member
 
Join Date: Jun 2009
Posts: 516
Default

You knpw it's a good idea when 2 ABI members post the same thing at the same time.
__________________
Cowon S9 32GB > HiFiMan RE0 (RIP) | Sansa Clip+ 16GB (Rockbox) > Soundmagic PL20
If you have problems, try MSC mode, then google.com
Reply With Quote

  #5  
Old 02-22-2010, 02:06 PM
tamalet tamalet is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Default

Thanks for the quick answer!!
About formatting it, I read that some people got into trouble by doing that. They said the player would not start after that.

Can I just format it and the copy the firmware files?
What's the file system, FAT32?
After installing the firmware will the folder structure be reconstructed or do I have to do it?

Thanks a lot for your help.
Reply With Quote

  #6  
Old 02-22-2010, 02:09 PM
tamalet tamalet is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Default

Quote:
Originally Posted by Syndrome View Post
Did you try the reset button when it was freezing? If I was you I would format the entire thing and start over. Put new firmware, and be sure to use MSC mode to add your music and then see how it acts after that.
Thanks for your answer.

I knew there had to be a reset button, I just couldn't find it yesterday night!!

I was also thinking about formatting it, but before I want to be sure that I won't screw it. I have some doubts about it, see my previous post.

Oh, and I already have the player in MSC mode.

Last edited by tamalet; 02-22-2010 at 02:18 PM.
Reply With Quote

  #7  
Old 02-22-2010, 02:47 PM
Syndrome's Avatar
Syndrome Syndrome is offline
Redneck Moderator
 
Join Date: Dec 2007
Posts: 1,278
Default

Yes its FAT32. You will format, then put the firmware on, and boot the player up, it will go through its setup and all that. Then make sure its on MSC mode, and plug it in then start putting your files onto it.
Reply With Quote

  #8  
Old 02-23-2010, 03:02 AM
tamalet tamalet is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Default

Done. It's working great now.

Thanks a lot.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:26 AM.