android
  #41  
Old 11-17-2008, 01:52 PM
fairbankswinter fairbankswinter is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Default

Hi Bobby RS!

Windows recognizes the player in the Device Manager as Creative Zen Touch with a questionmark next to it (unknown device?). When I plug it in (after uninstalling from the Device Manager) the "Found New Hardware Wizard" popup asks to help look for software. The player ONLY goes into the recovery mode when it is started or plugged into the computer (same thing). (I just checked and it does for a split second show firmware error before going into recovery.)
Reply With Quote

Advertisement [Remove Advertisement]

  #42  
Old 11-17-2008, 02:31 PM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

It sounds like (since you loaded the Touch with the PFS firmware) MTP is not properly installed. Make sure you have the WMP11 runtimes uninstalled (add/remove programs and check show updates box to see) and then reinstall WMP10. So, with the Touch booted into Recovery Mode, it is detected the same way?
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

  #43  
Old 11-17-2008, 03:00 PM
fairbankswinter fairbankswinter is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Default

I failed to say, the player froze while loading the pfs firmware, that is the basic problem... I did uninstall the wmp11 runtimes as well before installing wmp10. The touch only boots in the recovery mode (or I can't figure out how to boot it any other way...) so it is always being recognized the same way.
Reply With Quote

  #44  
Old 11-17-2008, 03:42 PM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

Ok, I got you now. Yeah, it will continue to boot into Recovery Mode until the firmware is properly installed. Try this:

- With the Zen plugged in, open Device Manager, and expand the Portable Devices category.
- Right click on the Zen's entry and select Uninstall.
- After the driver is uninstalled, disconnect the Zen.
- Boot into recovery Mode and do two Formats.
- In the mean time reinstall WMP10 again and restart.
- Then select Reload Firmware.
- When prompted, connec to the computer.
- Open Device Manager again to verify that the driver installed and loaded without error.
- Execute the firmware program again to reinstall the firmware.
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

  #45  
Old 11-17-2008, 03:59 PM
fairbankswinter fairbankswinter is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Default

So, I see the Creative Zen Touch appears under "? Other devices" and it says the device is not configured correctly... reinstall drivers.. It seems to be a problem with the driver (I thought that would be taken care of with the firmware... do I need to get a new driver somewhere? is there one you can recommend?)

tried it as you said, and it went the same way as up to now, still no dice.

I really do appreciate your taking time for me and my woes!!!
Reply With Quote

  #46  
Old 11-17-2008, 04:33 PM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

The problem appears to be with MTP and not just the driver. MTP supplies the driver. If MTP were working properly, the Touch wouldn't be showing up under the Other Devices category in Device Manager with an error. The firmware should have nothing really to do with the driver. The Touch should be recognizable and have its driver load whether you are booted into the Firmware or Recovery Mode; either or.
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

  #47  
Old 11-24-2008, 02:08 PM
fairbankswinter fairbankswinter is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Default

happily, I was finally able to get it going after all... on a different computer. now I am fighting to try to figure out how to get it recognized on this computer... the neverending story. got any more ideas or tips there?!

thanks again for your help bobby!
Reply With Quote

  #48  
Old 11-24-2008, 02:13 PM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

Good to hear you have it working again. Thanks for the update. It's no problem. Good luck with dealing with your computer.
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

  #49  
Old 01-25-2009, 02:06 PM
FeeshFood FeeshFood is offline
Junior Member
 
Join Date: Jan 2009
Posts: 2
Lightbulb

Unlike so many other people, I don't claim that this is "the best solution" or "nothing else will work but my solution" but what I do claim is that what I tried worked.

I've spent nearly 9 months trying to fix this and nothing worked until today.
I read all of the posts in this article and nothing worked so tried something myself.

Here is what I did:
1) Downgraded/rolled back to Windows Media Player 10
2) Installed Jukebox Drivers from here
3) Downloaded Jukebox Firmware Zen Touch P4S PCFW LB 2.11.01 from here
4) Ran the program and selected English
5) Clicked UPGRADE.

That's all I did and I finally got my Jukebox working again.
I hope so much that everyone else tries this and works for them also.

I've not found another mp3 player that works and sounds as good as this one.
Hope you're works after this too.
Reply With Quote

  #50  
Old 01-25-2009, 05:48 PM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

Good to hear FeeshFood. Thanks for posting. Although, this entire thread was about doing exactly what you did.
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

  #51  
Old 01-28-2009, 02:54 AM
FeeshFood FeeshFood is offline
Junior Member
 
Join Date: Jan 2009
Posts: 2
Help

Yeah I'm fully aware of that being that there's 3 pages in this topic and over 86,000 references to this problem as reported by Google..

I thought that it could be helpful to post what I did in order to get my jukebox working again with those specific files I linked to in my post.
Reply With Quote

  #52  
Old 01-28-2009, 08:49 AM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

I'm sure it will be helpful for others. Although I always recommend downloading the files from Creative directly before anywhere else. Thanks.
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

  #53  
Old 03-26-2009, 09:11 PM
z781 z781 is offline
Junior Member
 
Join Date: Mar 2009
Posts: 1
Default

Tried to load the update from the original the player came with.. creative zen touch 20gig .. unfortunately did it with windows xp wmp11.

It got to the stage of restarting, then popped up firmware problem and went into recovery mode. I closed the upgrade program which was not responding at that point after 30 mins. I reopened and plugged it in, player not recognized.

I have since downgraded to wmp 10. I have tried everything, with the drivers uninstalled it shows up in windows as a mtp device, with the drivers installed it shows up as creative zen touch.

I have uninstalled and re installed the drivers, all creative softeware and windows media player several times.

When the player is disconnected it goes into recovery mode and comes up with the menu options. I have tried everything, format.. etc.

Same problem with the popping up of update softare now only lasting for 1 second.. then the box closes.

When the player is connected to the computer there is no list of options to choose from as the player is docked in recovery mode.

Is no one reading this thread anymore?

Last edited by BobbyRS; 04-22-2009 at 10:42 PM.
Reply With Quote

  #54  
Old 09-09-2009, 09:57 AM
GaryJT GaryJT is offline
Junior Member
 
Join Date: Sep 2009
Posts: 1
Default Don't give up

I had the same problem, downloaded the firmware to a pendrive and tried the fix on various computers, on the 5th it finally worked. Just keep trying on as many computers as you can and it should work.
Edit: I forgot to mention the computer I got it to work on is running Windows Server 2003

Last edited by GaryJT; 09-09-2009 at 03:15 PM.
Reply With Quote

  #55  
Old 01-16-2010, 08:08 PM
hollylaird888 hollylaird888 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 1
Default

Hello,
firmware version.. I dont understand my zen micro is stuck in recovery mode. now whenever i turn on the zen touch .. it starts up to a screen where have 4 option..
clean up
format all
reload firmware
reboot

i cleaned up first then formatted it then did the reload firmware.. and then plug the cable in the computer.. the computer recognizes it as the zen touch but .. the upgrade program still says .. your player is disconnected please connect your player..
How do i fix this issue.. please help Holly
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:53 AM.