android
  #1  
Old 12-23-2009, 02:14 PM
savagess savagess is offline
Junior Member
 
Join Date: Nov 2009
Location: Australia
Posts: 35
Default Samsung Yp-R0 Album art how?

Hi All.
I suspect this is probably the same for all samsungs players, but I just received my 16gb YP-R0.

I noticed some Music have Album art show up, but most don't.
Using MP3 tag I can see image show up that shows on the player, so must be embedded as there is no image file within the directory,

I've then add image 200x200 pixels in size to an album but still doesn't show up on the player...

Any advise would be great, this is very frustrating!
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-24-2009, 01:13 PM
The Chief The Chief is offline
Junior Member
 
Join Date: Dec 2009
Posts: 10
Default

Quote:
Originally Posted by savagess View Post
I noticed some Music have Album art show up, but most don't.
Using MP3 tag I can see image show up that shows on the player, so must be embedded as there is no image file within the directory,
Rules of thumb:
1) ID3V2 2.3 tags only, NOT ID3V2 2.4. UTF-16, non-padded tags. Foobar2K can make (or rewrite other tag types into compatible format) id3v2 2.3 tags (you need to switch 'ID3v2 writer compatibility mode' ON).
2) No other tag types! No ID3V1, no APE tags!
3) JPG Cover Art, common format, NOT 'progressive JPEG', no more than 512K file, no more than 1024x1024 pixels.
3) Plant cover art into mp3's with TagScanner in 'ID3v2' write mode. Hell with EmoDio crapware, it's nothing but a HUGE pile of hindu-code shit.

Last edited by The Chief; 12-24-2009 at 01:18 PM.
Reply With Quote

  #3  
Old 12-24-2009, 07:01 PM
savagess savagess is offline
Junior Member
 
Join Date: Nov 2009
Location: Australia
Posts: 35
Default

Thanks got it working, only problem how do you make it do a lookup for the art work.
Unless I have the file already I can;t find a way to search for the art online...

Cheers

Don't worry, worked it out!!
so much better than EmoDio, and a lot faster!
Reply With Quote

  #4  
Old 12-25-2009, 03:26 AM
The Chief The Chief is offline
Junior Member
 
Join Date: Dec 2009
Posts: 10
Default

Quote:
Originally Posted by savagess View Post
Thanks got it working, only problem how do you make it do a lookup for the art work.
Unless I have the file already I can;t find a way to search for the art online...

Cheers

Don't worry, worked it out!!
so much better than EmoDio, and a lot faster!
Album Art Downloader is the best Cover Art downloader AFAIK. Enormous quantity of albumart search engines (via plugins, works out of-the-box)! Works hand in hand with Foobar2K (can choose albums from fb2k database).

Try it, it's really good.
Reply With Quote

  #5  
Old 01-09-2010, 05:04 AM
iampiti iampiti is offline
Junior Member
 
Join Date: Sep 2006
Posts: 40
Default

I guess not...but doesn't this support album art in files in the folder? e.g: In my old yp-z5 if you put a file named folder.jpg in the folder of the album the player would use that image as the album art for all the files in that folder.
Reply With Quote

  #6  
Old 01-09-2010, 05:24 AM
The Chief The Chief is offline
Junior Member
 
Join Date: Dec 2009
Posts: 10
Default

Quote:
Originally Posted by iampiti View Post
I guess not...but doesn't this support album art in files in the folder?
No, it's not. YP-R0 only supports embedded album art.
Reply With Quote

  #7  
Old 10-23-2010, 01:06 PM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Hi all - first post!

I just bought a 16 Mb Samsung YP-R0 player, and thanks to all the tips and advices in this site, I'm getting the most of it. Also, I updated firmware to v.1.22.

I am following your indications re: how to properly use tags, but I still have some ALBUM ART that DO NOT show on the player, both in internal memory and in a 16 Gb m microSD card (Kingston class 4), while others appear at once (even editing the R0 tags from the PC during USB connection).

I'm using Mp3Tag (v.2.45a) and tags are configured correctly as ID3V2 2.3 tags - UTF-16. Their size is usally 300x300 px. (Some larger pictures, 500x500, DO appear correctly, though).

I've tried some tip about deleting tracks first, and then copying them again, but just some images refuse to appear. It is not too frustrating, but I wanted to share it.

Thanks!
Reply With Quote

  #8  
Old 10-23-2010, 01:27 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,599
Default

Could you send me some files with an album art that doesn't display please?
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #9  
Old 10-23-2010, 04:24 PM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Here you have:

http://hotfile.com/dl/77906452/0cf28...m_art.zip.html

Both show the album art in the PC, but not in R0.

I can't find any difference between them, but then, I'm never cared much about tags, except religiously rename the fields to suit my style. I haven't started using album art until recently, and now, with my new R0 I sort of prefer it to the turntable!

Thanks a lot!
(ps: for some reason it wouldn't let me uploade the attachment directly to the forum)
Reply With Quote

  #10  
Old 10-23-2010, 06:05 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,599
Default

The reason is easy (unfortunately).
The R0 only displays album arts for MP3 files. You files are encoded in WMA.
Album arts are not supported with the formats WMA, OGG, AAC and FLAC.
This well-known issue cannot be fixed with a new firmware, it's due to the platform specifications...

PS: you have classical music encoded in WMA 64kbps, it shoud hurt any ear You should not encode your songs at less than 128kbps and classical music rather deserves mp3 VBR V0 or CBR 320kbps
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*

Last edited by lebellium; 10-23-2010 at 06:13 PM.
Reply With Quote

  #11  
Old 10-23-2010, 08:04 PM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Hi there again!
Thanks for your answer, but I'm afraid there must be something else: 80% of my music is encoded in wma, including most of the tracks that actually do display album art correctly in the R0; one of the tracks I uploaded (the largest) is wma and album art is OK. And at least I have an album in mp3 that does not show anything at all!!

Just some tracks show their album art and others don't. I just keep thinking about the image itself. Apparently one of the mp3-encoded albums that shows blank album art has a png image (as with all my album art, it shows Ok in Mp3Tag or in Quintessential player). I just saved it as standard jpg and substituted it for the png, but no image!!

I have attached my mp3tag options tab as it is configured now.

mp3tag_options.jpg

So, I'll keep trying. Thanks again for the help.


ps: as for the crappy compression I use, I'm afraid my hearing is not too good. I did some test a few years ago, and I barely heard any difference between 320, 160 or 64 , both with my MPIO HD300+Sony regular in-ear earphones, or with the Creative speakers in my PC. So, I rather have a larger part of my music collection with me than encoding more info than I can register!!
Reply With Quote

  #12  
Old 10-24-2010, 04:19 AM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,599
Default

Indeed, the album art displays for some WMA files but I don't know why. It may depend on the encoder and format (Windows Media Player 9, 10, 11 or another software/ WMA, WMA Pro, WMA Lossless). It's not a question of tags as there is only one tag version for WMA.
But officialy album arts are not supported with WMA files on the R0. There is a diffference between the 2 files you uploaded: frequency is 44100Hz for one and 48000Hz for the other one. That may be a reason too.

Regarding your mp3 files, your mp3tag settings seem to be correct (maybe unselect "write APEv2" and install the v2.46a or 2.46c beta). PNG album arts are not supported but JPG are supported. So that's strange the R0 doesn't display your JPG album arts. Try to remove the file from the R0, update the library, and transfer the file with the JPG album art again, and update the library.
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*

Last edited by lebellium; 10-24-2010 at 04:28 AM.
Reply With Quote

  #13  
Old 10-24-2010, 06:01 AM
||dav1de|| ||dav1de|| is offline
Junior Member
 
Join Date: Mar 2010
Location: Italy
Posts: 88
Default

There is a way to get album arts also on other file (I tried with a flac on the R1 file but I think it works with every file type also on the R0). First of all the player must be set in MTP mode, then drag & drop your file into player memory, if it's not inside yet, be sure that the file is correctly tagged at least for "album" and "artist", then convert the file in mp3, tag it (with also the album art) and synchronize it with windows media player, then delete the mp3 from player's memory. Turn on the player and try to play your file (the first one you put inside), the album art should work! For every album you want to get the album art you should synchronize just one tagged mp3 file. Synchonizing the mp3 will be create a folder called "album" in which are saved the album arts, if the player plays a file it will search inside this folder for the right album arts, also for non mp3 files.
__________________
dav1deser on hwupgrade.it

Last edited by ||dav1de||; 10-24-2010 at 06:20 AM.
Reply With Quote

  #14  
Old 10-24-2010, 06:09 AM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Quote:
Originally Posted by lebellium View Post
install the v2.46a or 2.46c beta
Did that last night. Still the same behaviour.

Quote:
Originally Posted by lebellium View Post
Try to remove the file from the R0, update the library, and transfer the file with the JPG album art again, and update the library.
That I did at the beggining. Twice. No go.


Quote:
Originally Posted by lebellium View Post
There is a diffference between the 2 files you uploaded: frequency is 44100Hz for one and 48000Hz for the other one.
Ok, just substituted the files: still nothing. And there's still the many mp3-encoded tracks that show blank album art: they're 44100hz, which is sort of more compliant.

Also, I have a case of a correctly displayed album art that's larger than 1000x1000 px and weighs 1 Mb!!
And it is the same for files stored in the sd card: some show art, some don't...

Anyway... I'm sending you two more examples encoded as mp3, one OK, the other blank.

http://hotfile.com/dl/78015397/031dd...mples.zip.html

I really appreciate your time!!
Reply With Quote

  #15  
Old 10-27-2010, 06:04 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,599
Default

I tried your 2 mp3 samples. The album art displays well for both. So no issue for me. I don't know why you have a problem with one of the files.
However, when I open them in mp3tag I can see the tag format is: "ID3v2.3 (ID3v1 ID3v2.3 APEv2)" I really advise you not to use the APE tag for mp3 files. So unselect "Write APEv2" in Extras>Options>Mpeg

For your WMA files you can try the solution of dav1de. I won't try it myself because I hate MTP and WMP...
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #16  
Old 10-27-2010, 07:12 PM
meetooman's Avatar
meetooman meetooman is offline
Member
 
Join Date: Oct 2009
Posts: 488
Default

Quote:
Originally Posted by ||dav1de|| View Post
For every album you want to get the album art you should synchronize just one tagged mp3 file. Synchonizing the mp3 will be create a folder called "album" in which are saved the album arts, if the player plays a file it will search inside this folder for the right album arts, also for non mp3 files.
I will try this. But what I know from MTP is that the "covert art" sample is linked to the "album" object, and then each "music file" has to be linked to the "album" object on the device. you can describe it as a chain: File(s) <--> Album <--> Cover.
Reply With Quote

  #17  
Old 10-31-2010, 04:55 PM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Hi again,

Puzzled by my variable results using different tagging programs, I tried deseseperate solutions, including Emodio, for tagging & adding album art. Well, apparently, Emodio does a great job at that, and most of the tags hold after syncing files and updating the library. Maybe the fact that Emodio does not support pasting a bitmap, only importing a jpg file has to do with that.

However, some times, for the album art to appear, I have to manually update the library. The problem is that often some albums that appear ok with the unplug-usb updating, just vanish. I plug the R0 again, the library updates again, and then I have both all albums and the recently added album art; 240x240 px files do just fine. However, I only use square images, and add a dull background to those that are slightly rectangular.

For the record, I have less than 5000 tracks in the internal memory, and less than 4 folder depth.

Thanks again to all suggestions
Reply With Quote

  #18  
Old 11-17-2010, 08:50 AM
giannibat giannibat is offline
Junior Member
 
Join Date: Nov 2010
Posts: 3
Default

Quote:
Originally Posted by The Chief View Post
Rules of thumb:
1) ID3V2 2.3 tags only, NOT ID3V2 2.4. UTF-16, non-padded tags. Foobar2K can make (or rewrite other tag types into compatible format) id3v2 2.3 tags (you need to switch 'ID3v2 writer compatibility mode' ON).
2) No other tag types! No ID3V1, no APE tags!
3) JPG Cover Art, common format, NOT 'progressive JPEG', no more than 512K file, no more than 1024x1024 pixels.
3) Plant cover art into mp3's with TagScanner in 'ID3v2' write mode. Hell with EmoDio crapware, it's nothing but a HUGE pile of hindu-code shit.
Hi Chief, how can realize this with mp3tag or other like The GodFather, TagScanner or MediaMonkey?
Reply With Quote

  #19  
Old 11-17-2010, 11:45 AM
The Chief The Chief is offline
Junior Member
 
Join Date: Dec 2009
Posts: 10
Default

Quote:
Originally Posted by giannibat View Post
Hi Chief, how can realize this with mp3tag or other like The GodFather, TagScanner or MediaMonkey?
Don't know, bro. What I really know is that you can do 1) & 2) with Foobar2000 with 100% success. You can convert other tag types to desired ID3V2 2.3 as well as stripe unwanted tag types from mp3. Foobar2000 itself worth trying as everyday media player, but it can also do LOTS OF useful things...

After that all you have to do is to write album art with TagScanner.
Reply With Quote

  #20  
Old 11-17-2010, 11:57 AM
giannibat giannibat is offline
Junior Member
 
Join Date: Nov 2010
Posts: 3
Default

Quote:
Originally Posted by giannibat View Post
Hi Chief, how can realize this with mp3tag or other like The GodFather, TagScanner or MediaMonkey?
ok just solved with mp3tag easily.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:18 AM.