android
Go Back   abi>>forums > MP3 Players By Brand > Cowon iAudio > Cowon S9

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-10-2009, 08:15 AM
123rabz 123rabz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Default Does the new firmware (2.41) decrease touchscreen responsiveness?

I have had my Cowon S9 32GB for a couple of days now, loaded about 3gig worth of music on it and ABSOLUTELY LOVED THE SOUND QUALITY. However, my player arrived with firmware 2.30 and the touchscreen was responding quite well. However, since updating to firmware 2.41, the touchscreen sometimes does not respond at all and at other times I have to press the same icon several times to get any response. Any idea what is causing this?

Thanks.

Last edited by 123rabz; 09-10-2009 at 08:30 AM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 09-10-2009, 02:43 PM
Bravepower's Avatar
Bravepower Bravepower is offline
Junior Member
 
Join Date: Nov 2008
Location: United Kingdom
Posts: 50
Default

I've noticed that my player (2.41 too) sometimes doesn't accept input for a few seconds as well. I hope Cowon fixes that soon. They've been really responsive to feedback so maybe you should let them know through email or on the official forums.

Some major touchscreen fixes were made in 2.41 though, so you might not want to revert. The previous firmware 2.31b2 reduced touchscreen response time when songs were playing, probably as a side effect of implementing gapless MP3 playback. Judging from the patch notes and my experience, 2.41 fixes that input lag time. 2.41 also improves the accuracy of the touchscreen. If you ever noticed that you tapped on screen and it selected above/arpund where you were aiming, this update fixes that problem.
__________________
Cowon S9 32GB Titanium | Creative Zen V Plus 8GB | Sennheiser CX 400 | Last.fm
Reply With Quote

  #3  
Old 09-10-2009, 04:32 PM
maikon maikon is offline
Junior Member
 
Join Date: May 2009
Posts: 35
Default

using 2.41 too and the responsiveness has reduce to a nightmare
sometimes when viewing pictre and want to go backo desktop i ave to press the m icons several times before it even responded to me
same when watching videos and music when it ges to sleepmode it takes 6 seconds to even respond and sometimes it doesnt even respond
Reply With Quote

  #4  
Old 09-10-2009, 05:00 PM
Mf1232's Avatar
Mf1232 Mf1232 is offline
Member
 
Join Date: Dec 2008
Location: Richmond, NH
Posts: 461
Default

its perfectly fine for me
__________________
16gb Sony NWZ-E475m - Sony MDR-EX300 IEMs
*R.I.P.*
16gb Cowon S9, 32gb ZuneHD
Reply With Quote

  #5  
Old 09-10-2009, 05:39 PM
123rabz 123rabz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Default Looks like I will have to go back to previous firmware

I will go back to the firmware that the player came with (2.30), it is sad that I have to do this, as I really enjoyed the reverb eq sound effects that came with firmware 2.41. Oh well..
Reply With Quote

  #6  
Old 09-10-2009, 05:46 PM
123rabz 123rabz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Default However...

I might still be able to create my own version of my fave reverb effect (stadium) using custom eq options. So maybe not all is lost
Reply With Quote

  #7  
Old 09-10-2009, 06:39 PM
mrigank.pawar's Avatar
mrigank.pawar mrigank.pawar is offline
Member
 
Join Date: Jun 2009
Location: Sydney, Australia
Posts: 135
Default

The new firmware is supposed to increase the touch responsiveness. Mine's working fine, too.
I am just annoyed with the pictures folder.
The sand-timer comes up when I'm scrolling down in thumbnail mode!
__________________
Cowon s9 (32gb)-Titanium
[Earphones/Headphones]:
(1)Sennheiser Px100 (2) Klipsch Image s4 white
[Amplifier]FiiO e5
Reply With Quote

  #8  
Old 09-11-2009, 09:09 AM
aki aki is offline
Member
 
Join Date: Nov 2008
Posts: 281
Default

yes I agree they should make the pictures screen more efficient, it is sluggish atm, no real trouble with the screen with the update, could be more responsive sometime but maybe thats due to space between glass and screen (dust is a sign of that)
__________________
Current Mp3 players:Silver Sansa Clip 4gb, Cowon S9 16GB Chrome
Past Mp3 players: Zen vision M 30gb, ZEN 8gb Headphones: Sennheiser CX400 Precision, PMX100/200
Reply With Quote

  #9  
Old 09-19-2009, 07:52 AM
Bravepower's Avatar
Bravepower Bravepower is offline
Junior Member
 
Join Date: Nov 2008
Location: United Kingdom
Posts: 50
Default

Quote:
Originally Posted by mrigank.pawar View Post
The new firmware is supposed to increase the touch responsiveness. Mine's working fine, too.
I am just annoyed with the pictures folder.
The sand-timer comes up when I'm scrolling down in thumbnail mode!
That's why I always use the file browser for pics instead of the thumbnail viewer.

And 123rabz, just remember that by reverting to 2.30 you lose gapless, JetEffect reverb and the improved touchscreen accuracy. Keep an eye out for new firmware versions though, they might speed it right back up again.
__________________
Cowon S9 32GB Titanium | Creative Zen V Plus 8GB | Sennheiser CX 400 | Last.fm
Reply With Quote

  #10  
Old 09-19-2009, 09:11 AM
coatessey coatessey is offline
Junior Member
 
Join Date: May 2009
Posts: 5
Default

At first 2.41 I did not notice any sluggishness however in the past week I have seen a decrease in sensivity. Hopefully this is rectified in the forthcoming release.
Reply With Quote

  #11  
Old 09-19-2009, 10:33 AM
RoloJam RoloJam is offline
Member
 
Join Date: Jul 2009
Location: Katy TX
Posts: 172
Default

I've noticed some sluggishness with switching song in matix view. It seems like it has something to do with the music that is "now playing". If I click the pause button, it tend to alleviate the sluggishness. Not sure, but I didn't notice this problem with firmware before 2.41. Hopefully they can isolate the problem and release a firmware patch.
Reply With Quote

  #12  
Old 09-19-2009, 02:12 PM
123rabz 123rabz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Default Works fine now

I have either gotten used to the occasional unresponsiveness, or it probably doesn't happen anymore. Either way, I am happy and will be staying with firmware 2.41. Thanks for all your replies.
Reply With Quote

  #13  
Old 09-20-2009, 05:37 PM
RoloJam RoloJam is offline
Member
 
Join Date: Jul 2009
Location: Katy TX
Posts: 172
Default

Quote:
Originally Posted by 123rabz View Post
I have either gotten used to the occasional unresponsiveness, or it probably doesn't happen anymore. Either way, I am happy and will be staying with firmware 2.41. Thanks for all your replies.
Glad things are better. I fixed my problem by changing the double click timeout within Claw's UI from 100 to 150. It's more responsive now.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:39 PM.