android
Go Back   abi>>forums > MP3 Players By Brand > iRiver > iriver P Series

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 07-21-2009, 04:11 PM
Olley Olley is offline
Ultra Senior Member
 
Join Date: Dec 2008
Posts: 4,894
Default

OK, so iriver finally responded to my latest email.

They advised me to download the Firmware Updater, and use it to RESTORE the firmware on my P7. Downloaded and installed it, even though I already had it installed and had tried this. Ran the installer until it asked me to connect my device, but with my P7 connected the Updater never sees it, so it won't go past that point to where I can tell it to RESTORE.

I replied to iriver support with this info. Now to wait for their response.

Olley
Reply With Quote

Advertisement [Remove Advertisement]

  #22  
Old 09-07-2009, 03:31 AM
configer configer is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Default

Hi Olley,

I guess I am in the same boat with you. The P7 does not turn on, I can see and use it as an external storage but no luck to connect it with iplus3 or firmware updater. If you find a way fix it please share with me. otherwise I have to return it. Thanks.
Reply With Quote

  #23  
Old 09-07-2009, 05:20 AM
maderin1's Avatar
maderin1 maderin1 is offline
Member
 
Join Date: Apr 2009
Posts: 187
Default

when running the firmware updateer does it ask you at all to install any drivers, or does a add new hardware wizard pop up at all

as this is a rockchip device at heart, for recovery special drivers are needed for the update/repair to be able to access the player in the correct way##so, does it ask for any drivers at all
Reply With Quote

  #24  
Old 09-07-2009, 05:38 AM
Olley Olley is offline
Ultra Senior Member
 
Join Date: Dec 2008
Posts: 4,894
Default

In my case the iriver software does not see the P7 when connected. It's a removable hard drive at best. Iriver support tried for a moment but now completely ignores any emails I send them. I asked for a RMA but have not gotten any response. Period.
Reply With Quote

  #25  
Old 09-07-2009, 07:48 AM
maderin1's Avatar
maderin1 maderin1 is offline
Member
 
Join Date: Apr 2009
Posts: 187
Default

well if you can see the main memory then this maybe a possible solution to get the player recognised again by the iriver software, this situation you have is common with rockchip, where the player is visible but dead

anyway, have a look at this guide to try and get the player in the right state

http://www.mp4nation.net/forum/viewt...hp?f=43&t=8488

you need to concentrate on the bit about getting special drivers installed - not sure if it will work but worth a shot
Reply With Quote

  #26  
Old 09-07-2009, 06:11 PM
configer configer is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Default

I heard P7's software only recognizes the device in MTP mode, while it works as an external drive it's in MSC mode. I wonder if we could change the mode from PC connection it may help the firmware updater to find the device. There is a P7U.sys file with mode=UM, is that related?

A usable device should not brick in any circumstances, at least there must be a way to restore it back to some state. like the iphone, a much better design.
Reply With Quote

  #27  
Old 09-18-2009, 02:16 PM
ShawnB26 ShawnB26 is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Default

Ok, so my P7 seemed like it crashed also as my computer would only see it as a removable drive. Contacted IRiver support and told me to send it back... so I tried something.

1. Connected P7 to computer
2. Clicked My Computer
3. Right click to 'Removable Drive'
4. Click to format
5. Quick format and start and wham bam thank you ma'am. It cleared everything out. Put my music back on. Everything seems to be working again. I hope this helps.

Last edited by ShawnB26; 09-18-2009 at 02:22 PM.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:12 PM.