android
  #1  
Old 06-25-2009, 06:54 PM
Monkeymann Monkeymann is offline
Junior Member
 
Join Date: Jun 2009
Posts: 9
Default Canot downgrade from beta firmware

Hi,

I wanted to try skinning up my sansa... I would have liked it pretty much if i could have been using the original firmware mi4 file... Mayby i could've?

I downloaded the lastest beta (the one with a barking black dog welcome screen).

I hated the fact that the beta came with only 4 languages.. Jewish, polski, english and another.... What i wanted was only French.

Earlier i did try rockbox beliving i would get a nice french interface but it kinda failed.. And rockbox doesnt even refresh its database and always ends up with an empty song base.

So yet, i am now stuck with that beta firmware and i canot either downgrade to the lastest stable version neither apply any h3mod theme (modded mi4 files).

When i launch the songpad sansa toy thing that isnt an ipod but mostly an mp3 player or such stuff of a name.... (blah..) ... by having the lock opened and pressing rec then power, then go to the 16mbformat partition, then put either the original firmware rom and mi4 or the modded mi4 theme file, then safely disconnect it, then remove the cable... The screen Quickly says ehmm.. (ill repeat the procedure so i get a proper quote)

(yet i guess that i better slash up the option of applying a theme and concentrate at downgrading the toy back to e200v101.02.24a)

It says

At opening line1[Mini-B->Device Mode] line2[USB2.02.0 MSD]

Then to the extractation of the original mi4 file.. Soft unplug.... and ill try to freeze the screen holding the power button so i can read and type.. (whish itll work)

"upgrade finished>resetting the system"

So it didnt even have the time to do anthing at all.

If i put that great Sansa.fmt folder file into the format partition, whitch would usualy launch the format procedure... It'll do the same, exiting without doing any procedure then relaunch unmodified.

Earlier in the day, i restored the sandisk sansa from a broken rockbox installation.. I've put the lastest stable firmware, backupped all files stored on the device, so they be safe, then i installed rockbox safely, disliked it, tried to return to sansa's original interface, got it to freeze at "refreshing database".... Used the sansa.fmt folder file technique, it worked greatly, the device worked properly, then i installed the beta firmware.

So now, i am pretty stuck with the choice to turn jew or to be stuck with a none-native interface in english.. Canot thematize the toy, canot downgrade, canot format or perform any modifications...........

I'll try with installing rockbox again so the toy gets altered off a bit then whish it will resolve the fact that the device became lazy at applying its usual procedures but i am pretty sure it will not work... Yet ill put all efforts i can :P

I suggest that the abi forum team puts a flashing red warning tag aside that beta firmware :P lol

So, yet, an help would be greatly appreciated because the sansa toy isnt mine but my cousin's :P lol


Thanx for reading


-Monkey-is-a-Matt
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 06-25-2009, 08:50 PM
Monkeymann Monkeymann is offline
Junior Member
 
Join Date: Jun 2009
Posts: 9
Default

Ok - Installation of Rockbox (after installing the beta firmware (e200fw01.03.01beta.exe)) succeeded :P At realy least

I'm probably going to leave it like this untill i fall on a proper way to downgrade the device to the lastest stable firmware .... Yet, the case is still opened :P

Cya

Later edit:

LOL Even worst now :P

I tried playing a videoclip then rockbox turned into a brown screen... Hard-powered-off - - - When rebooting, the bootloader from RB shows up then a few glitchy lines shows up... Then a delay... Then i have to chose language from the sansa default beta firmware screen..... The worst thing is that it doesnt delivers access to mpc drive anymore while plugged to the usb port of my laptop HAHA..... Huuh......

I'll try a last time to put a sansa.fmt file on the 16mbformat drive koz i still have access to it even if it became unefficiant because of the beta firmware's strangeness....

I even tried the "ultimate downgrade procedure" http://www.anythingbutipod.com/forum...owngrade+sansa but the software do not detect the sansa unit...... buuh XD

Gon come back tomorrow around here and continue my becoming troubleshouting journal HAHA..

[upgrade finished - resetting system]
Guess what:P No changes! - - - - Hmmm... Still - Seems like it erased rockbox's system files, but not the bootloader......
Mayby gon try downgrading again....
...Nope.. Still no access to either mtp or msc modes......
And Rockbox's evil bug is still on..... Seems like my Sansa is about to hit a wall

Cya

Later edit:

Good morning :P

Removing the battery for the night seems to have made no differance.

Last edited by Monkeymann; 06-26-2009 at 07:13 AM.
Reply With Quote

  #3  
Old 06-26-2009, 07:38 AM
Monkeymann Monkeymann is offline
Junior Member
 
Join Date: Jun 2009
Posts: 9
Default

The actual problem... That doesnt make my day at all... Is that even if i slowly get an access to the sansa's interface after rockbox crashing on boot, even if i select msc mode, the player doesnt remember my choice. Neither remember the chosen language between english, pollish, jewish or whatisitish... Each times i boot i have to wait rockbox to crash, sansa to load, chose language then turn it back off koz i cant get access to the 2gb partition even if selecting MSC mode.....
Reply With Quote

  #4  
Old 06-26-2009, 07:50 AM
Monkeymann Monkeymann is offline
Junior Member
 
Join Date: Jun 2009
Posts: 9
Default

Solved

<table border="0" cellpadding="0" cellspacing="5" width="100%"><tbody><tr><td nowrap="nowrap">
Quote:
<table border="0" cellpadding="0" cellspacing="5" width="100%"><tbody><tr><td nowrap="nowrap">advcomp2019 <script type="text/javascript"> vbmenu_register(&quot;postmenu_288810&quot;, true); </script>
Sansa Moderator
</td> <td width="100%">
</td> <td nowrap="nowrap" valign="top"> Join Date: Jun 2007
Posts: 4,841

No Classifed Ratings


</td> </tr> </tbody></table>
<hr style="color: rgb(134, 155, 191); background-color: rgb(134, 155, 191);" size="1"> You need to rename the older firmware and bootloader to firmware.mi4 from PP5022.mi4
and pribootLoader.rom from BL_SD_boardSupportSD.rom
and the sansa.fmt file onto the Sansa's recovery mode.
Well.... It resetted, removed the dark dog intro.... but it stays frozen to the sandisk logo....

I'll try at 4:30PM to reapply the firmware files with their original names so i re-get an interface XD
lol
Yet... I get the "connected" animation but no 2gb partition access.....
Recovery mode still availliable :P
Applying un-renamed mi4 and rom files...

Still stays stuck on the sandisk boot logo :S

HELP ME! haha :P


Managed to access the menu
with the fact i get the connected image.. disconnect.. the image is flashing and
i can see "usb, then msc" And i been able to apply the e200fw01.00.12.exe patch

But it still stays stuck on the boot logo after reboot
So, after connecting, disconnecting, i get access to the xxxx2 firmware.. at realy least :P
Otherwise, it would stay stick at boot....
Access to both format16 and 2gb partition is now correct...
Gon pry on that later on :P
Cya

Later edit:

Finaly managed to get e200fw01.00.12.exe to work correctly... After a few times applying it

Now the boot lenght is normal and the firmware is wrking fine :P

Sure thing is that it takes much time and efforts investments to modift the sansa toy :P

Thanx to all the forum users and experts for building that much informations sheets lol

Cya

Later edit:

Cool

I managed to install the green theme :P
Modified the firmware furnished with the e200fw01.00.12.exe patch :P

Now i guess it is about time that i gimp up a new theme and publish it on the ABI forum :P

Cya



*satisfaction sigh*
</td><td width="100%">
</td><td nowrap="nowrap" valign="top">
</td></tr></tbody></table>

Last edited by Monkeymann; 06-26-2009 at 10:10 AM.
Reply With Quote

  #5  
Old 08-17-2009, 12:33 PM
Shadowbiest69 Shadowbiest69 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 9
Default

I jesus i have the same problem and did it like you but there's the hanging in the boot picture at least
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:05 AM.