android
Go Back   abi>>forums > MP3 Players By Brand > SanDisk Sansa > Sansa e200 > Sansa e200 Firmware

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-07-2009, 06:25 PM
crazybatbfan crazybatbfan is offline
Junior Member
 
Join Date: Aug 2009
Posts: 2
Unhappy My Sandisk Sansa Won't Allow Me To Add Music...says it needs 6 MB...HELP!

Okay I made the mistake of using Windows to format my Sandisk Sansa E260 (4 GB) and now I can't get it to be recognized in Windows at all unless I am in recovery mode and then I get the folder popping up under My Computer calling it 16MB-Format. When I do re-boot it without using Recovery mode and unconnected from the USB I get a message that pops up saying:

Not enough space for MusicDB, please free 6 MB.

Can ANYONE help me? Please make all instructions in very simple terms. I just barely learned a few hours ago on how to get into recovery mode. All and ANY help would be so greatly appreciated.

P.S. I can still get onto the main screen and select the different things like music, photos, etc. and even still listen to the radio but I can't add any music or do anything with it beyond that. According the Info I have Version 01.02.18A. I also hopefully have included the only thing (called VERSION) that was found in the 16MB-Format.

PLEASE HELP! Thank you!
Attached Files
File Type: txt VERSION.TXT (512 Bytes, 2 views)
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 08-07-2009, 07:00 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,356
Default

I have repaired my Sansas that went wacky using the Ultimate Fix. Most often just using the sansa.fmt file and a safe disconnect fixed them. Hope you have backups for your files.

Good Luck.
Reply With Quote

  #3  
Old 08-08-2009, 03:59 PM
crazybatbfan crazybatbfan is offline
Junior Member
 
Join Date: Aug 2009
Posts: 2
Unhappy

Okay I tried the Ultimate Fix and now I get a message stating "Refresh Database Failed."

Now what can I do???
Reply With Quote

  #4  
Old 08-08-2009, 04:03 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Do you use the horrible MTP transfer protocol, or is your e200 normal MSC?
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #5  
Old 08-08-2009, 04:58 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,356
Default

The link I posted was the only one I needed to get my e250 up and going again. I had to do the steps several times (four I think) but eventually it worked. Dropping the the mi4 file and the sansa.fmt into the 16 mb recovery drive eventually worked.

There are other threads about the database refreshing problem but I have no personal knowledge of how to do that. There is also a thread a thread in the Rockbox Twiki on how to unbrick a Sansa V1 and how to use manufacturing mode in Linux.

Hope one of these works for you. Good Luck.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:56 PM.