android
Go Back   abi>>forums > MP3 Players By Brand > SanDisk Sansa > Sansa e200 > Sansa e200 Rockbox

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-31-2009, 12:42 AM
TheLongshot TheLongshot is offline
Junior Member
 
Join Date: May 2007
Posts: 38
Default Anyone know why the songs on my microSD card appear multiple times?

This has been a problem for a long time, but the Database has either been broken in the build I was using or something didn't work for some reason.

I've noticed that in the database that there are multiple entries for the songs that are on my microSD card. I'm not just talking about a couple, I'm talking about 40+ for each song. Each album has about 500+ entries. It makes it tough shuffling my collection when I mostly get whats on the SD card.

So, what's the deal here? How can I prevent it short of removing the card?

Jason
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-31-2009, 11:32 AM
ecarlson ecarlson is offline
Junior Member
 
Join Date: Mar 2007
Location: Sterling, VA
Posts: 44
Default

What happens when you do an "Initialize Now" on the database?
__________________
- Eric, http://www.invisiblerobot.com/
Reply With Quote

  #3  
Old 05-31-2009, 12:29 PM
TheLongshot TheLongshot is offline
Junior Member
 
Join Date: May 2007
Posts: 38
Default

Quote:
Originally Posted by ecarlson View Post
What happens when you do an "Initialize Now" on the database?
That is what it does, since I've tried that already.
Reply With Quote

  #4  
Old 05-31-2009, 01:34 PM
ecarlson ecarlson is offline
Junior Member
 
Join Date: Mar 2007
Location: Sterling, VA
Posts: 44
Default

Have you tried reformatting the MicroSD card and putting the files back on after that? Maybe the directory structure on the card is messed up somehow.

If you "Initialize now" without the MicroSD card installed, is the database clean?
__________________
- Eric, http://www.invisiblerobot.com/
Reply With Quote

  #5  
Old 05-31-2009, 11:32 PM
TheLongshot TheLongshot is offline
Junior Member
 
Join Date: May 2007
Posts: 38
Default

Quote:
Originally Posted by ecarlson View Post
Have you tried reformatting the MicroSD card and putting the files back on after that? Maybe the directory structure on the card is messed up somehow.

If you "Initialize now" without the MicroSD card installed, is the database clean?
Well, I did the second and the database was fine. Unfortunately, I can't test the first because when I removed the card, it went flying across the room.

I haven't found where it has landed yet. Damn, that's one strong spring in the Sansa...
Reply With Quote

  #6  
Old 05-31-2009, 11:59 PM
ecarlson ecarlson is offline
Junior Member
 
Join Date: Mar 2007
Location: Sterling, VA
Posts: 44
Default

Quote:
Originally Posted by TheLongshot View Post
. . . Unfortunately, I can't test the first because when I removed the card, it went flying across the room.

I haven't found where it has landed yet. Damn, that's one strong spring in the Sansa...
LOL
__________________
- Eric, http://www.invisiblerobot.com/
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:52 AM.