android
  #1  
Old 12-28-2006, 05:42 PM
nightech nightech is offline
Junior Member
 
Join Date: Dec 2006
Posts: 1
Default Insignia freezes while building library

I just got the 2GB Insignia MP3 player and have run into an issue. . . I tried to drop some music into the music folder on the MP3 player and it started to build the library. . . Now the screen says "building library" and gets to 251 and stops, then i just sits there untill it turns its self off. . . Anyone else seen or had this problem and know how to fix it??? I was told it is fixable but that it will cost me $40 for someone at the store to tell me how to fix it. . . Any help would be great. . .

Thanks
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 01-01-2007, 10:07 AM
harryg harryg is offline
Junior Member
 
Join Date: Dec 2006
Posts: 75
Default

Perhaps one of your songs is corrupt. Try adding songs 10 at a time to see if it "hangs" during any particular batch of ten you are loading.

Are you simply loading the songs from within windows explorer? If yes, you need to switch the player to MCS mode.

Have you updated to the newest firmware at the Insignia-products.com website? If not, do it!!

Hope this helps.

BTW... I use Windows Media Player 10 and/or 11 to add songs to the player and it works fine. Don't give up on that player.
Reply With Quote

  #3  
Old 07-16-2007, 11:26 PM
hijjt hijjt is offline
Junior Member
 
Join Date: Jul 2007
Posts: 2
Default Building library Problems

I have this same issue in firmware 1.2, it has happened on 2 players, and I cannot get the players to do anything. There is no usb detection, so I can't reflash the firmware, and the reset is useless. One player is stuck on building library.. 7 and the other is at 75. Any help resolving the issue would be great.
Reply With Quote

  #4  
Old 07-17-2007, 09:31 AM
Mr. Microphone Mr. Microphone is offline
Junior Member
 
Join Date: Jul 2007
Posts: 21
Default

If you haven't read my problems with the 1.2 F/W update, click here...http://www.anythingbutipod.com/forum...ad.php?t=17427

The ultimate damage is that I lost USB connection, too. Windows doesn't recognize the player, and the player doesn't search for the PC. I had to re-format the drive so there no media files at all on my player.
Reply With Quote

  #5  
Old 07-17-2007, 10:17 PM
hijjt hijjt is offline
Junior Member
 
Join Date: Jul 2007
Posts: 2
Unhappy I wish it was that easy

I backed up my media to a folder on my desktop, not a lot of media, probably not even a hundred songs. I then updated the firmware with the automatic firmware updater, got the error about database full, initialized it and formatted the internal media, and loaded the songs back onto the player, waited for the ok disconnect and then safely removed it from windows. From then on I have had nothing but building library.. 7 on the screen. The second player I did the firmware update on worked a little longer, I got through loading some songs on it the first time. The second time I loaded songs onto it, the same exact error comes on the screen this player makes it to 75 instead of just 7. Effectively I have 2 brick players that do nothing but display Building library..7 or building library..75. Why is there no way of escaping the building library, or a catch in the firmware that stops this from happening, or maybe a little better clue as to what I could have done to hose them so badly they will not boot by simply adding music to them. Is there any kind of recovery modes available to this player, I have tried the hold in either position with no difference in behavior, the reset button is about the most useless thing ever, it does about the same thing as removing the battery and reinserting it. I have tried plugging it into usb without battery attached, in either mode of hold, holding down each of the keys, and to no avail, nothing, just a frustrating reminder of the fact that song 7 or song 75 may in some way be corrupted, but there is no way of fixing it.
Reply With Quote

  #6  
Old 08-01-2007, 01:59 PM
caratbox caratbox is offline
Junior Member
 
Join Date: Jun 2007
Posts: 5
Default

anybody have or know of a fix for this "building library" freeze?
i have the BT model, only powers up via USB and stops at song number whatever...BB is no help they say they can only replace not repair (but no BT model exists anymore so thats no help) and insignia tech support tells me to go to my local BB. I am in a loop. Any insight would be appreciated.
Reply With Quote

  #7  
Old 08-16-2007, 10:49 AM
caratbox caratbox is offline
Junior Member
 
Join Date: Jun 2007
Posts: 5
Default

anybody have an answer/fix for this?
Reply With Quote

  #8  
Old 08-16-2007, 12:37 PM
Tobey's Avatar
Tobey Tobey is offline
Insignia Moderator
 
Join Date: Oct 2006
Posts: 1,500
Default

If your player gets stuck building the library (which is extremely rare), there isn't much you can do, as it won't connect to the computer so you can format it (which would fix it).

I say cut your loses, and take it to BB where they'll probably exchange it for a non-BT model.
Reply With Quote

  #9  
Old 08-16-2007, 03:34 PM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,609
Default

Or, depending on when your warranty expires and how long you can stand to wait, hold onto it until the "future family of Insignia players" arrives at Best Buy and exchange for one of those...
Reply With Quote

  #10  
Old 10-07-2007, 12:07 PM
luckyy luckyy is offline
Junior Member
 
Join Date: Jul 2007
Posts: 7
Angry

So this just happened to me today... loaded up an audio book (which I've had on there before..) and it's stuck at building song 111... period, thats it, kaput.

Wonderful to see there is NOTHING that can be done about this???? If it can't build a library, it's bricked? Thats absolutely absurd... why in the hell don't they make it bring up the usb instead of the library when it's connected to the usb bus, so you could manage it's flash?

Last insignia device I waste my money on.
Reply With Quote

  #11  
Old 05-20-2008, 05:22 PM
coffee-turtle coffee-turtle is offline
Junior Member
 
Join Date: May 2008
Posts: 7
Lightbulb Insignia NS-4V17 - Master Reset

I couldn't believe how hard it was to find any information on just resetting the player if it was freezing.

I was modifying the Media Library manually and noticed that folder names had no spaces. I accidentally included a folder or two with spaces. So when I disconnected it from my PC, I experienced exactly what you good folks described here in this thread. The thing would freeze at Building the Library. I almost took this thing apart trying to figure a way to fix it.

However, I did finally figure it out today and I thought I should post my findings.

Code:
1) Hold the power button (slider) in the on position for about 15-20 seconds to force the player to turn off.
 
2) Hold the menu button down and simultaneously hold the power button (slider) to the on position.
 
3) Do not let go when the device turns on. You will then get a screen message in black and white that reads (with a typo):
 
WARRING !!!
 
NAND FLASH MEMORY INITIALIZE......
 
"WARRING !!!" will appear in red (and probably should read "WARNING". You will have the options of "No" and "Yes".
 
4) Choose "Yes" to re-format your device.
Yes, you will lose all your music until you synch up again, but atleast the device is now working as if it was first taken out of the box.

I hope this helps!!!

I can't believe I couldn't find this documented anywhere... or maybe I didn't look hard enough. But I'm glad I stumbled across it and can share it now.

Enjoy! Your device is now un-bricked!!
Reply With Quote

  #12  
Old 05-20-2008, 06:41 PM
nobs nobs is offline
Member
 
Join Date: Jan 2007
Posts: 156
Default

Great find coffee-turtle.
This might work on the NS-DVxG.
Do not have a "stuck @ re-build brick" but I did boot to an "Erase Internal Memory" promt on the 1.930b FW

Can anyone confirm that the NS-DVxG can really erase by a simple menu & power press on a locked 1.2 or 1.930b player?
__________________
Buying inferior DRM lock music is successful for the RIAA
but only with ignorant consumers.
Buy used CD's and resell 'em
Reply With Quote

  #13  
Old 12-03-2008, 04:13 PM
coffee-turtle coffee-turtle is offline
Junior Member
 
Join Date: May 2008
Posts: 7
Default

creating folder names with spaces or odd characters may also cause the problem. (y)
Reply With Quote

  #14  
Old 03-02-2009, 06:41 AM
Basilis88 Basilis88 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Default

I have a 2g NS-2V17 and I'm getting the same issue, although less permanent. The player worked well up until today. I recently purchased an 8gb microSDHC card and worked towards filling it with a ton of music. Then I ran into a dilemma, I couldn't play songs from both my flash memory and my msd card through a .m3u playlist. I called tech support and they said it isn't possible, so I moved all my songs on to my msd card and made the playlist for the card only (figuring I'd put my movies, pics, etc. on the flash memory). After renaming all my folders and songs to the same format (a ton of work) and making the playlist (also a ton of work), I inserted the card and got the standard "Building the Library" screen. It froze at 851. I read this thread and used coffee's idea to erase the flash memory, which made it reset back to normal (with the card out). Every time I put the card in, same error happens. Then I read something about "odd characters" in folder names, so I changed my "Ill niÑo" folders to "Ill Nino". Reinserted the stick, and now it stops at 520. So I feel like the renaming of folders at least had an effect on the problems. Hope this helps, if you guys figure out what the exact problem is and how to fix it, please let me know. I really love my sport
Reply With Quote

  #15  
Old 03-02-2009, 06:50 AM
Basilis88 Basilis88 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Default

Odd, just finished renaming all my folders using only A-Z "-" and spaces. Now it freezes at 812.

I'll keep poking at it until it works I suppose.

EDIT: More random info

The song it was originally freezing on (#851) doesn't exist. There are only 815 songs on my memory stick.

Song #520 (2nd freeze) would be:
I:\Music\RATM - ST\09 - Township Rebbelion.mp3 @ 128 kbps

Song #812 (3rd freeze) would be:
I:\Music\Trapt - ST\08 - When All Is Said and Done.mp3 @ 128 kbps

So the only thing I can think of is that Self-titled CDs ruin things.
Not much of a theory but I hope some info helps.

EDIT: FIXED WOOT

So I ended up deleting I:\Music\RATM - ST\09 - Township Rebbelion.mp3 and I:\Music\Trapt - ST\08 - When All Is Said and Done.mp3 from my memory stick and BAM, worked again.

Just reuploaded both files and it still works...

Odd issue.

So I guess my suggestion for fixing (if you have a way to access the files) is to figure out what song it was stuck on (I used calculator), delete that song. Try it again. Delete the next song it's stuck on. Repeat until it works. Then reupload the songs you deleted and cross your fingers. Not a great plan but it worked for me :P

Last edited by Basilis88; 03-02-2009 at 07:20 AM. Reason: Updating
Reply With Quote

  #16  
Old 05-08-2009, 11:38 AM
coffee-turtle coffee-turtle is offline
Junior Member
 
Join Date: May 2008
Posts: 7
Default

Sorry, what did you use to access the files? (Glad you figured out the songs causing the freezing).
Reply With Quote

  #17  
Old 05-08-2009, 03:41 PM
Basilis88 Basilis88 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Default

I used the USB reader that came with my microSD card. If you're just using the internal memory you're probably going to have to format it using the menu button thing. If so, someone suggested putting 10 songs on at a time and checking it every time, that should work. I just use my internal memory for photos and videos that way I can just swap out my microSD card to my phone, computer, etc.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:38 PM.