android
  #1  
Old 05-05-2009, 03:54 AM
InstantCoffee InstantCoffee is offline
Junior Member
 
Join Date: May 2009
Posts: 46
Default Got my P2 Today!!

Yes, got my p2 today and 15 minutes of fiddling around with eq and stuff got it to sound quite good and started to enjoy it more and more. then bang the ep-370 earphones that came with them busted.. the left started going funny. been fighting with noel lemming and samsung for over 2 months to get this p2 after they messed up my s3. and to find the earphones already randomly breaking is a big let down =/. has anyone else had any experience with these earphones breaking ?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-05-2009, 02:24 PM
koralex90 koralex90 is offline
Junior Member
 
Join Date: Jun 2006
Posts: 96
Default

^ you shouldnt blast any pair of earphones like that from the start. Start low volume and make it used to blasting sound. I did that and my earphones started buzzing and breaking just like yours after a few times of use..

I didnt use it for a month but after my senheisers broke on me, i went back to using them and now they seem to work fine again!
Reply With Quote

  #3  
Old 05-05-2009, 02:58 PM
The DarkSide's Avatar
The DarkSide The DarkSide is offline
Ultra Senior Member
 
Join Date: Feb 2008
Location: Qns Vlg, NYC
Posts: 16,037
Default

The op never said he was listening to his music at excessive volumes, only the the earphones broke almost immediately.
Reply With Quote

  #4  
Old 05-05-2009, 06:25 PM
curiouswonderer's Avatar
curiouswonderer curiouswonderer is offline
Ultra Senior Member
 
Join Date: Sep 2007
Location: vancouver, bc
Posts: 1,316
Default

1. did you plug the jack in all the way?
2. does the headphones work with other players? and vice versa, does other headphones work with the p2?
__________________
"I don't think, therefore I am not"
Reply With Quote

  #5  
Old 05-05-2009, 06:48 PM
InstantCoffee InstantCoffee is offline
Junior Member
 
Join Date: May 2009
Posts: 46
Default

1. Yes i plugged in all the way
2. Havent tried on another play because i havent got 1 that will go loud enough to notice.

once i hit over 20 volume (21+) thats when u start to hear the left earpeice bass sound really crappy. i have another set of earphones from the u3 that samsung replaced for my s3 1 time but had the s3 replaced for the p2 mp3. curious can you please read my post about earphones in general discussion ive seen some of ur posts adnd looks like you know a bit.
Reply With Quote

  #6  
Old 05-05-2009, 07:35 PM
curiouswonderer's Avatar
curiouswonderer curiouswonderer is offline
Ultra Senior Member
 
Join Date: Sep 2007
Location: vancouver, bc
Posts: 1,316
Default

i really don't know all that much about earphones, but i will try my best to help

also, which one is that? link?

ALSO, i suggest not putting the volume that loud (it only goes up to 30, right?), it will blow the headphones, which might be what happened to yours.
__________________
"I don't think, therefore I am not"
Reply With Quote

  #7  
Old 05-05-2009, 07:37 PM
InstantCoffee InstantCoffee is offline
Junior Member
 
Join Date: May 2009
Posts: 46
Default

http://www.anythingbutipod.com/forum...ad.php?t=42829 there ya go its 1 of the top ones
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:37 PM.