android
  #1  
Old 12-02-2008, 11:27 PM
indieaz indieaz is offline
Junior Member
 
Join Date: Dec 2008
Posts: 22
Default HandBrake users? Help... [SOLVED!]

Using handbrake to convert some DVD sources.

I'm using version 0.9.3 in Windows (GUI). I must use the GUI...i'm making a tutorial for a non-computer savy person to put videos on their Sansa (more accuratly, to drop their DVDs on there for watching when traveling).

I've used a variety of the presets (iPod ones) and tried using my own settings (mp4 file, h.264 video, 500-1000kbps, 29.97fps and 25fps, 320x240 resolution, AAC downsamples to stereo as 128kbps and 160kbps). I can drag/drop the files onto the View, but when I go to play any of them I make it tells me the media is in an unsupported format.

What is the secret? I see some forums posts where people are using "ipod low rez" preset...that doesn't exist in this version or I'd try it. Based on Sansa's format page (http://www.sandisk.com/sansa/faq/faq21.asp) the videos I'm making should work. What gives?

Anyone using 0.9.3, and if so what settings are you using?


SOLVED!

After messing with HandBrake for about 6-7 horus I seem to have found what works. It seems some of the advanced options being passed through most of the presets causes issues.

-Start with the "Classic" preset.
-You should be able to change the resolution as needed according to the "supported resolutions" thread.
-I use 500kbps for the bitrate. This provides more than sufficient quality for 320x? video with 23.97fps. I had no problems with 1000kbps either if you wsant higher qualityf or playback elsewhere.
-Set frame rate to 23.97 - I have found using 29.97 or 24 causes audio/video sync problems. Using 23.97fps i can fast forward/rewind as needed withotu any sync issues.
-Audio I used mp3 codec, 160kbps stereo. Other setting seem to be fine as well...audio seems to have no impact.

It seems what was causing my grief is some of the advanced values being passed to the encoder by the other presets I was starting with. Getting H.264 to work is so difficult I gave up. quality wise on a 320x240 screen there really is nothing to be gained by using it IMO.

Last edited by indieaz; 12-29-2008 at 05:37 PM. Reason: Solved
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-03-2008, 12:41 AM
advcomp2019's Avatar
advcomp2019 advcomp2019 is offline
Ultra Senior Member
 
Join Date: Jun 2007
Posts: 4,838
Default

It could be the issue that I found: http://anythingbutipod.com/forum/showthread.php?t=31708
Reply With Quote

  #3  
Old 12-28-2008, 08:38 PM
indieaz indieaz is offline
Junior Member
 
Join Date: Dec 2008
Posts: 22
Default

Still not getting any love :-(

Any more ideas?
Reply With Quote

  #4  
Old 12-29-2008, 05:15 PM
indieaz indieaz is offline
Junior Member
 
Join Date: Dec 2008
Posts: 22
Default

Solved.

After spending hours messing with Handbrake I seem to have found what works.

Start with the "Classic" preset. Use an mp4 container with ffmpeg mpeg-4 codec.

Set frame rate to 23.97fps (very important, at 29.97fps, or 24fps I get audio/video sync problems)

I set my bitrate to 500kbps since this is sufficient as far as i'm concerned with a 320x240 resolution at 23.97fps, but I had success trying 1000kbps as well.

Audio is AAC 160kbps, downsamples to stereo.
Reply With Quote

  #5  
Old 01-25-2009, 09:48 PM
numtre numtre is offline
Junior Member
 
Join Date: Jan 2009
Posts: 4
Default

Thx for this, I'll try later!
Reply With Quote

  #6  
Old 01-26-2009, 11:11 AM
numtre numtre is offline
Junior Member
 
Join Date: Jan 2009
Posts: 4
Default

It works 100%

i tried it with handbrake for linux!

thx a lot!
Reply With Quote

  #7  
Old 09-17-2009, 09:49 AM
WayneKerr WayneKerr is offline
Junior Member
 
Join Date: Sep 2009
Posts: 1
Default

I joined just to say thanks for posting this. I bought the sansa view used and didn't have any software. the software I downloaded didn't convert any files I had. Now I can hook my view to the portable DVD player screens in the van. No more scratched DVDs!
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:41 PM.