android
  #21  
Old 08-15-2008, 02:02 PM
musichound musichound is offline
Off-Topic Moderator
 
Join Date: Jun 2007
Location: Staten Island, NYC
Posts: 2,057
Default

If you are using the correct headphones you will not need to worry about this.
Reply With Quote

Advertisement [Remove Advertisement]

  #22  
Old 08-16-2008, 04:09 AM
The DarkSide's Avatar
The DarkSide The DarkSide is offline
Ultra Senior Member
 
Join Date: Feb 2008
Location: Qns Vlg, NYC
Posts: 16,032
Default

Just get the Bass Ferq's - I have em' and for $30.00 on Amazon ya' can't go wrong!!! The bass is clean, mids and high's are solid. Overall a pleasure to listen to at that price.
Reply With Quote

  #23  
Old 08-23-2008, 12:03 AM
dr13zehn's Avatar
dr13zehn dr13zehn is offline
Junior Member
 
Join Date: Dec 2007
Location: Missssippi
Posts: 46
Default

If you're on a budget, try the JVC FX33, do a Kramer mod on them (very easy), plug them into one (just one) Fiio and you should have enough volume and bass to keep you happy.
The FX33s are about $10 and the mod is pretty much free.
__________________
Cowon D2 16GB - 2.57, Sandisk Sansa Clip 4GB, 5.5Gen iPod Video Rockboxed, iPhone 3G
Corda 2Move, Minibox E+, Fiio
Shure SE530PTH, Ultrasone HFI780, Etymotic ER-4P->S Customs, Sennheiser MX90 VC, Razor ProTone m250
Reply With Quote

  #24  
Old 09-15-2008, 11:53 PM
no9's Avatar
no9 no9 is offline
Moderator
 
Join Date: Jul 2008
Location: West Michigan
Posts: 1,098
Default

I've got Senn 300's and have used the V-moda bass freq's and if I turned the volume to the 30's on my D2 with those in my ears I'd cry like a little girl with a skinned knee. Don't mess with the amp/amps. Five of them wouldn't help as much as either of these phones would. I had the same problem with some cheap JVC buds I had and I solved it by buying better buds. If you really want bass get 300/bass freq and these http://www.complyfoam.com/ You'll bleed from the ears believe me I just tried tried it.
__________________
Cowon S9,Sansa Clip+,
Sansa Fuze,Westone UM2,Altec Lansing UHP336

Last edited by no9; 09-16-2008 at 12:21 AM.
Reply With Quote

  #25  
Old 09-17-2008, 12:00 AM
Jack4L's Avatar
Jack4L Jack4L is offline
Ultra Senior Member
 
Join Date: Sep 2006
Location: Finland
Posts: 1,510
Default

Using 2 FiiO's with my im716s makes them sound more like really bad CX300s... Yuck.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:51 AM.