android
Go Back   abi>>forums > MP3 Players By Brand > SanDisk Sansa > Sansa Clip / Clip+ / Clip Zip

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-11-2008, 10:39 PM
unpocoloco unpocoloco is offline
Junior Member
 
Join Date: Mar 2008
Posts: 25
Default Get "MTP Media Player" popup on plugin, but can't open device (computer savvy folks?)

Hi all,

Well, I just bought the Clip despite my concerns about the ID3 tags (see "File Folder browsing mode" ). $80 for the 4GB at Target, but $70 at Costco...and then an additional $10 off. $60 for the 4GB? WOW!

But I have one major problem: I can't get it to work on my computer. I get the following when I plug in the player:


* I have no idea what the first option is, but selecting it doesn't do anything.
* I can Transfer Files using WMP, but it's difficult to browse through my music library that way.
* "Organize media files on this device using Creative Media Explorer" does nothing. Literally, nothing. It's as if I hit Cancel.


Shouldn't I be able to just see it as a hard drive and copy my files over?? I am certain it is my computer that is the problem, not the mp3 player. But I have no idea how to fix this one.

Suggestions? Much appreciated!
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 06-11-2008, 10:59 PM
advcomp2019's Avatar
advcomp2019 advcomp2019 is offline
Ultra Senior Member
 
Join Date: Jun 2007
Posts: 4,838
Default

Have you tried MSC mode? You can drag and drop your music into the Clip.

If you do not have MSC mode, you might want to read the stickies and update the firmware.
Reply With Quote

  #3  
Old 06-12-2008, 04:04 PM
Click Click is offline
Junior Member
 
Join Date: Jan 2008
Location: Chicago area, USA
Posts: 40
Default

Sorry if this is redundant, but here's a bit more detail:

Check your firmware version on the Clip's Settings menu; if it's 0.20 or above you can set the USB mode (also in Settings) to MSC mode and then use drag-n-drop to manage your files.

If your fw is 0.18 or below (there was no 0.19), you don't have a choice to select MSC mode - it's MTP or "auto" - but you can

turn on the clip
hold down the center button (keep holding it)
plug in the USB cable
wait until detected as hard drive on your PC
release center button

to force MSC mode. Then you can drop the new FW file in the root folder of the Clip, cycle power, and the FW will be updated. You can download the FW file on Sansa's site or here on ABI, v0.29 is the latest.
Reply With Quote

  #4  
Old 06-13-2008, 07:21 PM
unpocoloco unpocoloco is offline
Junior Member
 
Join Date: Mar 2008
Posts: 25
Default

Thanks all! I updated from WMP9 to WMP11 and that appears to solve the problem. I have really been avoiding "upgrading", because I liked how WMP9 displayed my files more, but so it goes. Apparently there is some framework built into WMP10 and WMP11 that mtp needs. Why not build it into the OS?!? Crazy to me.

I'm still going to look into the MSC mode as you suggested, so thanks for the tip! At least my Zen M player and Clip now actually work
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:01 AM.