android
  #1  
Old 05-12-2008, 05:29 PM
chrisjs162216 chrisjs162216 is offline
Ultra Senior Member
 
Join Date: Oct 2006
Location: Somewhere
Posts: 1,515
Default Dead Sansa

Yup, it happened again. I managed to brick yet another Sansa.

Since I don't feel like telling a life story of what's happened the past day, I'll try to keep it short. Basically, I was working on making a guide to help people who bricked their Sansa, and had about 1/3 of it done, in which the bootloader was damaged (which seems to happen fairly often). This of course meant I was playing with fire by purposely 'bricking' my Sansa, but since I've always known that e200tool can recover it, I didn't worry much.

The only problem is, I went and placed an invalid i2c file on the recovery mode partition, and the Sansa froze while writing it. I initially continued to think that it was no big deal, as e200tool could fix it, and went along hard resetting my Sansa. On restart, it was how I expected it - scroll wheel on, display off. Connected it to my computer, and ran ./e200tool init. Only problem is, it didn't detect the Sansa. Restarting the Sansa, I tried it a few more times, but it still didn't work. Turning to lsusb, I saw that the computer didn't even recognize the Sansa at all - not as a Sandisk device nor a PortalPlayer device. Since then, I've been confused, and have been on IRC asking questions as well as talking to kugel and Jeton.

I finally decided to try running a USB sniffer, and tested plugging in a flash drive to make sure everything was working. Lots of text scrolled through that I didn't exactly know how to read, but at the same time, I knew it was working. Unplugged the flash drive, and plugged in the Sansa -- nothing. Unplugged the Sansa and plugged it back in a few times, and nothing appeared in the log.

In some unknown way, from what it seems, I managed to kill my Sansa beyond Preboot mode. First for everything, I suppose, but this pretty much goes against what I've believed in - that it isn't possible to brick the Sansa without hardware modifications.

Back when I bricked my first Sansa, I found that it seemed as if the I2C is stored on the daughterboard, as I had killed the daugherboard on my first Sansa, but still got to Preboot mode. I tried removing the daugherboard, thinking it might do some magic, but it still didn't work. Removing the battery and booting only with power over USB also didn't work. Differences between whether or not hold/center is on/held didn't work. I've basically somehow managed to brick a Sansa beyond repair.

Now the question is, what should my next MP3 player be? It's going to be from Sandisk either way, but I'm mostly wondering whether to get a (used) e200v1 so that if I have time to continue my build, I'll be able to test it on a real Sansa, or whether I should get an e200 or Fuze and help with the V2 development.

Helping with the V2 development would be kind of limiting in a way, as there's no known recovery mode, but it was also mentioned that if all the developers agreed on code to be tested, someone could test it, and if it bricked their Sansa, the Rockbox team would send them a replacement.

However, the only reason to get a v1 is to continue the build and (possibly) help with SansaLinux development. Continuing the build can be done mostly via the simulator, so I'm kind of wondering...

Any suggestions on which to get?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-12-2008, 05:58 PM
kugel's Avatar
kugel kugel is offline
Rockbox Developer
 
Join Date: Dec 2006
Location: Berlin, Germany
Posts: 1,153
Default

Quote:
Originally Posted by chrisjs162216 View Post
...Basically, I was working on making a guide to help people who bricked their Sansa...
That's called irony.

I'm sorry for you, but as you said, you played with the fire.
__________________
;;
Reply With Quote

  #3  
Old 05-12-2008, 06:32 PM
donutman25 donutman25 is offline
Member
 
Join Date: Nov 2006
Posts: 108
Default

This happened to me about 3 weeks ago. My solution was giving up. I didn't use my sansa for about 3 days when i tried again and suddenly it was recognized in HAL on my computer (Kubuntu Hardy). After that was another set of headache to get e200tool to recognize it but eventually (2 hours) it did. I noticed similair problem with other electronics of mine. When I deem them "bricked" and try to fix them it usually fails, but if i let them sit for a while and try again it becomes recoverable. Maybe time will heal your sansa's wounds.

@chrisjs I noticed the you used e200tool init, is that the old version of e200tool because the version i have does not have to have that command passed to it.
Reply With Quote

  #4  
Old 05-12-2008, 07:07 PM
chrisjs162216 chrisjs162216 is offline
Ultra Senior Member
 
Join Date: Oct 2006
Location: Somewhere
Posts: 1,515
Default

Quote:
Originally Posted by donutman25 View Post
This happened to me about 3 weeks ago. My solution was giving up. I didn't use my sansa for about 3 days when i tried again and suddenly it was recognized in HAL on my computer (Kubuntu Hardy). After that was another set of headache to get e200tool to recognize it but eventually (2 hours) it did. I noticed similair problem with other electronics of mine. When I deem them "bricked" and try to fix them it usually fails, but if i let them sit for a while and try again it becomes recoverable. Maybe time will heal your sansa's wounds.

@chrisjs I noticed the you used e200tool init, is that the old version of e200tool because the version i have does not have to have that command passed to it.
Wouldn't be the first time something like that happened, so I'll try again in a few days. However, since I did try it on three different computers (each with a different kernel version) I'm not sure what the success rate will be.

I was using v0.2.3 of e200tool, which is the latest version, and has init. From what I can tell, init is what uploads e200code to the Sansa that allows the rest of e200tool to work.
Reply With Quote

  #5  
Old 06-01-2008, 05:49 AM
justshams justshams is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Default

can anybody give me the link to download the e 200 tool??
Reply With Quote

  #6  
Old 06-01-2008, 05:56 AM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

Quote:
Originally Posted by justshams View Post
can anybody give me the link to download the e 200 tool??
http://daniel.haxx.se/sansa/e200tool.html
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:22 AM.