android
  #1  
Old 10-02-2007, 11:19 PM
fftowdf fftowdf is offline
Junior Member
 
Join Date: Oct 2007
Posts: 2
Default Please help, as my Gigabeat MEV30 won't turn on.

I've been using my gigabeat now for 2 months w/ no problems. I just ran the battery dead a couple days ago, which I have done before, and it's been no problem, but now, even after plugging it in, in multiple different working outlets, it won't show that it's charging or turn on. I've tried resetting it, turning the battery off, and intertwining those two steps together, but nothing works. If anyone knows anything about fixing this, I need the help. Thanks
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 11-01-2007, 04:02 PM
tennisjunkie tennisjunkie is offline
Junior Member
 
Join Date: Nov 2007
Posts: 3
Default same problem

did you ever get it fixed??
Reply With Quote

  #3  
Old 11-01-2007, 09:05 PM
tennisjunkie tennisjunkie is offline
Junior Member
 
Join Date: Nov 2007
Posts: 3
Default

Mine is fixed now. i had the same problem. all i did was turn off the battery and unplug it then turned the battery on again and it reset itself. try it... i hope it works for you.
Reply With Quote

  #4  
Old 12-26-2007, 12:15 AM
OG1502 OG1502 is offline
Junior Member
 
Join Date: Dec 2007
Posts: 5
Default

Happened to me 2 just used a pin to press reset.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:55 PM.