android
  #381  
Old 05-31-2007, 02:12 PM
chrisjs162216 chrisjs162216 is offline
Ultra Senior Member
 
Join Date: Oct 2006
Location: Somewhere
Posts: 1,515
Default

Quote:
I have a crash with your latest build rockbox when trying to play videos from my microSD card(There are just videos on it)
I think the "stackf..." error message is shown.I couldn't read it exactly
Also deleting the .cfg file did not help.
The booting time takes also very long compared to the former builds from you.
Now I switched back successfully to your build from yesterday(070530).
*panic* stkov sd?

Try the custom build cpchan mentioned for those having that problem (either this page or the previous page)

Advertisement [Remove Advertisement]

  #382  
Old 05-31-2007, 02:36 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by xandl12 View Post
I think the "stackf..." error message is shown.I couldn't read it exactly
Can you please reproduce it and writ dowm the exact error.

Quote:
The booting time takes also very long compared to the former builds from you.
I presume this is with a card inserted.

The MicroSD patch is still quite immature- there are still some problems. Be patient.

Charles

  #383  
Old 05-31-2007, 02:46 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by godess View Post
In your latest build the Sansa slows down again when I listen to music while browsing through the files/database/etc.
I have no slow down at all. I suspect it is the multifont patch. Try setting a font manually in the settings or follow the directions on the page of that patch and report back.

Charles

  #384  
Old 05-31-2007, 02:46 PM
cmaines cmaines is offline
Junior Member
 
Join Date: Dec 2006
Posts: 11
Default

The slowdown because of the microSD patch probably means it's working better now. The Database is finally properly including files on the microSD card. In previous builds, I had to remove the microSD card before initializing the database or else it would never build one; it would usually just crash halfway through and I'd have to reboot. I'll gladly put up with a couple of seconds longer boot up time as long as I get a complete database of files.

  #385  
Old 05-31-2007, 02:50 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by chrisjs162216 View Post
Try the custom build cpchan mentioned for those having that problem (either this page or the previous page)
It will be the same because Toni folded the size increase into his new patch- hotswap1.patch. However, if you look at the patch page, you will see people are have problems. I think I am going to revert to my older patch in the next build to see if things are better for people.

Charles

  #386  
Old 05-31-2007, 03:04 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by cmaines View Post
The slowdown because of the microSD patch probably means it's working better now. The Database is finally properly including files on the microSD card.
Ah, this could be it. I don't have a MicroSD card, so I can't test it out.

Charles

  #387  
Old 05-31-2007, 03:44 PM
kugel's Avatar
kugel kugel is offline
Rockbox Developer
 
Join Date: Dec 2006
Location: Berlin, Germany
Posts: 1,153
Default

I don't have an MicroSD as well!

  #388  
Old 05-31-2007, 05:45 PM
dzr dzr is offline
Junior Member
 
Join Date: Oct 2006
Posts: 77
Default

Any idea about battery usage issues?

I was using last night's patched firmware... I had 39% battery life according to Rockbox... and it got used up in 15 minutes of audio.

Even getting to 39% went way too quickly (with the day before's build).

I don't have anything fancy set... (I just checked, I didn't even have the pitch raised, which I thought I may have).

  #389  
Old 05-31-2007, 05:51 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by dzr View Post
Any idea about battery usage issues?

I was using last night's patched firmware... I had 39% battery life according to Rockbox... and it got used up in 15 minutes of audio.
No, I haven't used my Sansa much for the last couple of days. I will test it out tonight.

Charles

  #390  
Old 06-01-2007, 01:16 AM
lazka lazka is offline
Junior Member
 
Join Date: Apr 2007
Posts: 16
Default

Is battery charging with rockbox working now? It seems to work but I remember some info somewhere, where it said it's not working properly...

The OF pisses me off because it stops charging at 3/4 no matter what i do.

  #391  
Old 06-01-2007, 01:58 AM
stuibb stuibb is offline
Junior Member
 
Join Date: May 2007
Posts: 45
Default

Sorry to be a dumbass but where have the file links gone?

edit: sorry problem solved... what timing, he was just reuploading them when I posted...

  #392  
Old 06-01-2007, 02:08 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by lazka View Post
Is battery charging with rockbox working now? It seems to work but I remember some info somewhere, where it said it's not working properly...
It is working, but not as efficient as the OF:

http://forums.rockbox.org/index.php?topic=10597.0

Quote:
The OF pisses me off because it stops charging at 3/4 no matter what i do.
Hum. it sounds like a battery problem.

Charles

  #393  
Old 06-01-2007, 02:22 AM
xandl12's Avatar
xandl12 xandl12 is offline
Junior Member
 
Join Date: Oct 2006
Location: Austria
Posts: 67
Default

Quote:
Originally Posted by cpchan View Post
Can you please reproduce it and writ dowm the exact error.

I presume this is with a card inserted.

The MicroSD patch is still quite immature- there are still some problems. Be patient.

Charles
Did a test right now with the latest build today and yes the error is

*panic*
stkov sd

I tested it with two different microSD cards 1GB and 2GB ...

Playing videos -->*panic* stkov sd (every time reproduceable)
Deleting files works
Copying files to microSD card works(mp3)
playing mp3's from microSD works

xandl12

  #394  
Old 06-01-2007, 03:05 AM
xandl12's Avatar
xandl12 xandl12 is offline
Junior Member
 
Join Date: Oct 2006
Location: Austria
Posts: 67
Default

I just tried the "simple branch" build and now I get the error
"Prefetch abort
at C0EDBABE"

edit: BUT AFTER SECOND TRY IT WORKS with his build!

  #395  
Old 06-01-2007, 03:06 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Test build without dc-bias patch.

Charles
Attached Files
File Type: zip rockbox_test_1.zip (1.12 MB, 2 views)
File Type: zip rockbox_test_2.zip (792.9 KB, 2 views)

  #396  
Old 06-01-2007, 03:10 AM
chrisjs162216 chrisjs162216 is offline
Ultra Senior Member
 
Join Date: Oct 2006
Location: Somewhere
Posts: 1,515
Default

I got the impression that he never tried the stack fix build...

  #397  
Old 06-01-2007, 03:15 AM
xandl12's Avatar
xandl12 xandl12 is offline
Junior Member
 
Join Date: Oct 2006
Location: Austria
Posts: 67
Default

well ... I tried the builds from the first site .. did I miss something?

  #398  
Old 06-01-2007, 03:20 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by chrisjs162216 View Post
I got the impression that he never tried the stack fix build...
Don't know. He said that he tried today's build (which I uploaded not too long ago). This has Toni's latest patch which includes the stack increase. The strange thing is that he claims it works with jac0b's simple build. I know for a fact that jac0b is using the same hotswap1.patch which I resynced with SVN yesterday.

Charles

  #399  
Old 06-01-2007, 03:27 AM
xandl12's Avatar
xandl12 xandl12 is offline
Junior Member
 
Join Date: Oct 2006
Location: Austria
Posts: 67
Default

So tried your "test" build" ...still same behavior *panic* stkov sd

Tried jac0b's build again ...first time accessing videos ..prefetch error --reboot it works

  #400  
Old 06-01-2007, 03:39 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by xandl12 View Post
So tried your "test" build" ...still same behavior *panic* stkov sd

Tried jac0b's build again ...first time accessing videos ..prefetch error --reboot it works
Ok, try this older buiild:

http://www.anythingbutipod.com/forum...&postcount=349

It will eliminate some possibilities.

Charles

Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:17 PM.