android
  #1  
Old 01-25-2011, 09:58 AM
karel karel is offline
Junior Member
 
Join Date: Jan 2011
Posts: 3
Default Water in my Sony NWZX1050 stopped working

Hi, I wondered if anyone has any advice. I have not had this walkman long and paid quite a lot for it. Today I picked it up from a work surface and there was a splash of water underneath it, some of this has enetered the walkman and I can see the film of water inside. I have no idea how it got in as it looks well sealed. Is there anything i can do apart from just leaving it to dry, although its that well sealed there seems to be no place for it to go or any air to get in to dry it. I have tried to look at opening it up but there seems no way to get into it.

If anyone can help or advise it would be greatly apprciated.

Paul
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 01-25-2011, 10:40 AM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

If you havenít turned it on, donít as turning it on could fry it Ö anytime an electrical device of mine gets wet I take it apart as much as possible, leave it in my car a few days as itís warm/hot where I live and test it after itís dry. Last thing I revived and working great is wifeís cell phone that went to bottom of pool but I had to replace the battery as the original didnít make it. If it doesnít work when dry, if you can replace the battery or send it in for them to do, it still may work fine.
__________________
WalkGood,
Ramůn

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #3  
Old 01-25-2011, 10:59 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

Yup...Try WG's tips. Also, possibly put the device inside a container of uncooked rice or some other dessicant for a few days.

Just don't turn the thing on at all until several days using either suggestion - WG speaks truth!

Good luck man and do post back after a few days.
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #4  
Old 01-25-2011, 12:01 PM
Ascariss's Avatar
Ascariss Ascariss is offline
Member
 
Join Date: Nov 2007
Location: Poland
Posts: 431
Default

I would agree with the above posts, do not turn on the device, let the water evaporate then turn it on, give it a good week of drying to be on the safe side.
__________________
-Ascariss - Sony Crew
Reply With Quote

  #5  
Old 01-25-2011, 04:11 PM
karel karel is offline
Junior Member
 
Join Date: Jan 2011
Posts: 3
Default

The device was on when the water got in im afraid and hands up I tried to use it and take my files of it etc. So all I can do now is leave it to dry and see what happens, there just seems no way to open it up, no screws or anything. If it is fried then can Sony not fix it, they have a returns on their uk site. Also it may be worth looking into what home insurance i have the walkman cost me 280, so it would be worth paying to fix or claim on if possible, just not sure if sony could help.
Reply With Quote

  #6  
Old 01-27-2011, 03:43 AM
ultrapony ultrapony is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Default

Oof. Fingers crossed.

If all else fails, there are teardown instructions in the service manual:
http://forums.sonyinsider.com/index....manual-in-pdf/

The adhesive looks icky to pull up though. You might need a hairdryer to prevent damage to the glass.
Reply With Quote

  #7  
Old 01-31-2011, 07:09 AM
karel karel is offline
Junior Member
 
Join Date: Jan 2011
Posts: 3
Default

Quick update: The screen has come back up fine with all the icons, i cannot though play anything, the touch screen does not work and the play button at the top oif the device does not help, it is stuck in pause mode.

Would it be worth leaving it to dry further or ringing sony and asking if they can fix it?
Reply With Quote

  #8  
Old 01-31-2011, 07:44 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

Hmmm, man not sounding too good to me. I would begin contacting Sony and pleading ignorance...IMO, Do NOT mention the dip in the pool if you want to try and get an exchange. But yes, to repair it for sure full disclosure probably best.

Sorry man and good luck!
-les
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #9  
Old 01-31-2011, 07:56 AM
Ascariss's Avatar
Ascariss Ascariss is offline
Member
 
Join Date: Nov 2007
Location: Poland
Posts: 431
Default

Let it dry maybe further, if not try the reset button otherwise I'd go with lestatar's suggestion.
__________________
-Ascariss - Sony Crew
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:59 AM.