abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Zen Xtra / Touch (http://www.anythingbutipod.com/forum/forumdisplay.php?f=115)
-   -   Zen Xtra Firmware Problem Fix (http://www.anythingbutipod.com/forum/showthread.php?t=9829)

walkertron 02-15-2007 07:04 AM

Zen Xtra Firmware Problem Fix
 
To Fix any problems with broken firmware form attempted "playsforsure" firmware updates etc where your pc finds it as a 20mb drive and it sits in recovery mode and does bugger all:
(fix courtesty of cinderlee in creative forums)

1. Uninstall all creative software & drivers
2. Uninstall Media Player 11 and Media Player 11 runtime (will require a reboot for each thing). This is done by going to add/remove programs and uninstalling (this will put your pc back to wmp10).
3. Re-install the Zen Driver from the creative website and reboot
4, Plug Zen in.
5, Make sure you have the firmware update ready, run it but don't click the language bit yet), leave the mouse hovering over your language selection.
6. On the Zen- select "reload OS"
7. As soon as it flashes up "reload new firmware now via USB" click the language button
8. Tada, now the pc should find it and allow you to re-load the firmware. (it may take a few attempts)
9. Once complete, click close and restart the pc. Everything should now be fine.
10. once you are happy you can re-install WMP11 and it will work fine.

Cheers!

TruePrometheus 04-08-2007 10:06 PM

It works ... thanks a lot!!!

possaci 05-11-2007 09:29 AM

Thanks a lot walkertron for this detailed instruction, especially steps 5 - 7!

It solved my firmware problem with the 60 GB ZEN XTRA .

I had contacted the CREATIVE customer support by Email and they promised help within 1 to 3 working days - after waiting in vain for 5 days, I found your instruction. So I'm happy now.

It's not a good reference for the official customer support of CREATIVE, is it?

sandlane 05-28-2007 03:03 PM

Can u please help?
 
I am having the exact same problem with my ZEN XTRA 60 GB. When I try the instructions above, the firmware software says that my player is not connected, even though it shows it as 20 MB storage device!

Can anybody please help??

ZenChick 05-28-2007 03:33 PM

Ummm... 20 Megabytes???

It sounds as if your player's filesystem is corrupt to the point that it won't even allow a firmware reload. Hopefully you've got a backup of everything on your player, because you're probably going to have to reformat its drive from the Rescue Mode menu. Before you take that extreme, though, try doing a Disk Cleanup, and see if that fixes the problem. Either way, once you restore connectivity to your computer, you should reload the firmware, as it's likely gotten corrupted as well.

sandlane 05-29-2007 08:54 AM

Fixed!!
 
I am not sure what it was, but I had to try it on three computers before I was able to load the new firmware. It was painful and agonizing, and I am glad it is over.

Thank you for your support!

ZenChick 05-29-2007 12:40 PM

Glad you got it working! :D

I only wish I could get mine working again...

zugzug 06-14-2007 11:16 AM

thanks for the info
 
Thanks for the help, walkertron

Guess i was kinda late to update my firmware but I did so yesterday on my 30gig zen xtra and it became unusable. Then i googled a bit and found out i was not alone.

I uninstalled everything mentionned in the first post except the "Creative Jukebox Driver" that appears in the add/remove programs because my player would not get completely re-installed at step 4 for some reason. I had a few PCs to play with and the result was the same on all of them.

Everything worked fine after that and my player is back to life with the new firmware... don't know if it was worth the trouble but its done. :)

scoobie 07-07-2007 03:33 PM

Grr.

I think I have to accept that my Zen Xtra 30GB is gone. I tried all the steps above (numerous times) on two different computers, and even resorted to re-formatting the unit from Rescue Mode. (it was showing the 20MB storage device on My Computer). The firmware is surely corrupted and I have had to hard-reboot the player when it freezes up.

Does anyone else have any more ideas before I put it in the Closet of Doom?

thanks.:)

Lamri 08-07-2007 04:20 AM

Having tried everything kindly posted here to help, nothing worked for my Zen Xtra 40 gig (it got to the stage where I had reformatted my Laptop and just put basic XP on with no MP11 etc etc but the Zen wasn't even showing as being connected at all :( )

Purely out of desperation I removed the drive and mounted it into a 2.5 inch HDD Caddy.
It turns out that the drive wasn't partitioned! I ran Partition Magic and formatted it as a FAT drive and re-installed it into the Zen, plugged the zen back into my PC and hey presto! Firmware reinstalled with no problems and it now works again.
Comparing the cost of replacing the Zen and buying a 2.5 Inch Caddy, it was definitely money well spent (roughly 10).

Try it if you are at your wits end, it may work for you as it did for me :)

JulieR 10-29-2007 09:22 PM

I, too, have a Zen Xtra 60GB that will not install the firmware. I've done all the above (with the exception of repartitioning), and it simply will not load.

The player shows up in "My Computer" as a 20MB storage device, as with someone else up above.

So. Now it's reformatted. I don't have the installation CD that came with the player. Where do I go from here? (I was able to back up all the mp3s before this all began, so I haven't lost data. But I'd really like to actually be able to *use* the player...)

I'd really appreciate your assistance. Thanks!

ORR 11-04-2007 02:53 PM

Thank You!!!!
 
Thank you for these precise instructions. Worked perfectly!!!
I had my nomad rusting in a drawer for more than a year and now it is back and fully functional.
Now, here is what I want to share:
The original 40gb HD of my unit was broken because of a fall. So when I tried to replace it with a STD laptop HD, the firmware upgrade failed, and I gave up. Yesterday a friend of mine sent me this forum and NOW I have an 80gb Nomad!!!
It seems ANY laptop HD can be used on this mp3 player, beautiful, I love it!

goon 02-25-2008 04:24 AM

can get mine into rescue mode but nothing else,it then says firmware problem,have tried reloads but no joy,it says 20gb when it should read 60gb,the bin is beckoning.

lilocowboy 02-26-2008 12:39 PM

You are AWESOME walkertron
 
I have been racking my brains out trying to get my Zen Xtra MP3 player to work again for the last week. I could go into all that I did but all I did was follow your instructions line by line. I will list the files I used in the process so someone can take what you put here and the files that I used and hope it works for them as well as it did for me.

Driver: #1 - Creative ZEN and Jukebox Driver 2.01.00

Firmware: #1 - Creative Zen Xtra PlaysForSure Firmware 2.10.03

Application: #8 - Creative Software Suite for PlaysForSure-enabled Creative NOMAD Jukebox Zen Xtra Players

I REALLY like Application #8 because I can just put my music on my Zen Xtra like I would from one HD to another HD. And I can put them on it in a way where songs won't dupe even though they are not by the same artist.

Artist <folder>
(Year) Album <folder>
01-Title Of Song <track 1>
02-Title Of Song <track 2>

etc.

Goon try this, I had the same exact problem as you and it did work. Just follow it as walkertron writen at the top

Scarletflame 03-20-2008 03:10 PM

Absolutely brilliant!

Took a while to get there (my PC takes ages to reboot) but this worked first time.

Thanks walkertron. :)

TheUberKraut 03-28-2008 11:56 AM

Yeah, so I bought an upgraded 130GB zen xtra.. and to my dismay the damn thing erased all the music I put on it when I took the battery out one time. Don't worry, the hard drive didn't change the space left either. So... I had to try to format the drive and somehow I managed to uninstall the firmware as well.

I'm left with a paperweight. Mine does the same 20MB Storage Drive thing as mentioned above. I'm going to try this fix on my other computer, because it won't work on mine for some reason. Wish me luck. I'll let you guys know how it goes.

TheUberKraut 03-30-2008 12:29 AM

Guys, I've run into a roadblock. I did all the steps above, but the thing is, the firmware installer still won't recognize my xtra. In device manager it shows up as nomad zen xtra, in the taskbar it shows up as MTP device, but it seems to be non-existant in My Computer. Is there something that I've forgotten?

The only thing that I can think of is that I've got an audigy 2 sound card installed... Do I need to uninstall that too? I don't see how that would have an impact...

And is there some reason that the people above were forced to "try this on 3 computers before it worked?" Is that what I need to resort to?

TheUberKraut 03-31-2008 12:10 AM

After you uninstall everything and reinstall the driver, the player should come up as Nomad Zen Xtra, not MTP Device... right?

gonzalezbr 04-04-2008 05:54 PM

ok hum.... i use vista.
so i went to a friends house, started doing the firmware update, and then got back home, left the mp3 charging for the first time(yay tomorrow gonna have some music!)
when i wake up.... this stupid thing =/
so now its already late night again, i'm here, tried to fix this whole day, didnt get it - poing is, i've got access only to one computer with xp, and my pc with vista
isnt there a .bin or something i could load into the 20mb hd? isnt there a hacked version for the firmware? isnt there a way to use it in vista?
i've tried all this you said - still it doesnt work. Even reformatted my friends pc for him, and still couldnt get it working
in xp, it isnt even recognized
in vista, i get the 20mb storage media....
any clue?

chrisbarker20 04-12-2008 11:08 AM

Mine won't work!!!
 
Hello,

Just joined as I have a 30gb Zen Xtra. Used it for years and years every day. Upgraded my PC recently to a Vista machine and my Zen won't work. Head to Creative website, read that I need latest firmware, download and try to install (on my old XP Home machine)

Now I'm stuck in 'rescue mode v1.13' I've tried all the instructions on the forums and it won't update the firmware at all.

I have today formatted the HDD on my old XP machine and clean installed XP service pack two. Making sure I didn't install any Creative items or updated Media Player. Still the firmware application will not recognise my player, keeps saying it's not connected.

Installed the Creative driver, still the same. I've followed every bit of advice and forum guide but cannot get the firmware updated or installed.

Is there any way to manually put the firmware onto the drive? Anything? Otherwise I'm off to buy and ipod!


All times are GMT -5. The time now is 07:12 AM.