abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Clip / Clip+ / Clip Zip (http://www.anythingbutipod.com/forum/forumdisplay.php?f=119)
-   -   Clip+ won't turn on and not recognized by PC (http://www.anythingbutipod.com/forum/showthread.php?t=71441)

Vovad 12-31-2012 07:52 AM

Clip+ won't turn on and not recognized by PC
 
So I bought my dad a clip+ for christmas and he has been enjoying it, but he brought it back to me this weekend saying it didn't work anymore.

I've tried two different usb cables (the ones provided with the clip) to get it recognized. The "found new hardware" action happens in the bottom- but eventually fails saying "failed to install device driver software". Nothing shows up in My Computer. This is Windows 7. It didn't work in my dads computer either which is XP.

I can't turn it on to format and I can't upgrade/change the firmware because I am unable to see the device. I've also tried the whole MTP/MSC thing but haven't seen any success- but I could be doing it wrong.

Any ideas?


Rockbox is not loaded on this particular device.

skip252 12-31-2012 08:05 AM

Sounds like it's time for a return. It's doubtful you're doing it wrong. It should be a simple plug and play procedure. Since it isn't and you've tried it on more than one PC with more than one cable that seems to narrow it down to the player.

If you can't return it to the seller I'd contact sandisk. As long as you have the receipt or some other proof of purchase from within the last year they shouldn't give you a hassle about an exchange.

Vovad 12-31-2012 08:11 AM

Yeah I was thinking it would come down to that- thought you guys might have some trick up your sleeve I was unaware of :P

Thanks anyways and I appreciate the quick response!

skip252 12-31-2012 08:25 AM

You could try forcing a MSC connection by following the directions here http://kb.sandisk.com/app/answers/de...r-sansa-player. If that works and you can get it recognized as a drive you may be able to fix any files system problems or uninstall it from the device manager.

File system corruption caused by removing it during a file transfer is the only thing I can think that might cause what you're seeing. Other than that I'd guess that you have a bad one.

JK98 01-01-2013 01:33 PM

I have found that all the Sandisk Clip+ players I bought were a bit messed up when new, but after a format using the player's menu they were fine. Now the first thing I do after taking a Clip+ out of the package is to format the player using the player's menu(then I set the usb mode to MSC, update the firmware if needed, then reset the usb mode to MSC if a firmware update was done).

Mikerman 01-01-2013 06:44 PM

Have you tried turning it on by holding the on button down for 30 seconds (or more)?


All times are GMT -5. The time now is 12:13 PM.