abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   iriver H Series (http://www.anythingbutipod.com/forum/forumdisplay.php?f=113)
-   -   iriver H340: new hard disk won't ever boot up (http://www.anythingbutipod.com/forum/showthread.php?t=70559)

powysa 09-14-2012 08:22 AM

iriver H340: new hard disk won't ever boot up
I recently replaced the defunct 40 gb hard drive with an 80gb one, listed as one of those compatible with this player (Toshiba MK8007GAH). Have formatted the new disc in FAT32 using various tools (incl. Swissknife). PC recognises disk when USB connected, I can transfer files to it with no problem.
BUT iriver player does not ever boot up the disk, constantly gives CHECK HDD CONNECTION error. It also seems to refuse to upgrade firmware, even when I try transferring the H300.hex file to the player - it just ignores the upgrade request. When I try to use the Rockbox software also on the player this gives various ATA errors (usually -11).
I have another similar player, and its 40gb hard disk works fine in this player too, so neither the player nor the new hard disk seem to be the issue - just the software connectivity between the two...
I'm not very technical - is there something fairly simple I'm missing?? None of the electronic shops/technicians I've contacted seems to want to have anything to do with these players. I'm at my wit's end. Thanks for reading.

jumbuck 09-16-2012 05:06 PM

Hi Powysa

First thing to check is that its not a apple branded drive. They have a apple logo on the lower left corner as shown below.
Also if the drive was purchased as a used drive it may have been fitted to a ipod as a replacement drive and formatted to suit.
Ipod drives have a extra partition for the firmware which makes them unsuitable for use in iriver players. I do recall some getting them to work but also remember a lot of failures.

Things I'd try are to

1) Do a full format with windows to another type of file system (eg: ntfs) and then reformat back to FAT32.

2) If you know somebody with a apple computer get them to format the drive for you.

3) Try GParted a linux based partition editor which you can run either from a linux live cd such as Ubuntu or from a live cd or USB stick http://gparted.sourceforge.net/livecd.php.

Good luck with it and let us know how you get on.


powysa 09-18-2012 02:39 AM

Hi Garry, many thanks for your reply.


The drive doesn't appear to be Apple branded.
It was bought as 'Taken from a working Sony VGN-TX2XP Laptop'.

I'll try your suggestions - fingers crossed.
Thanks again, Alan.

jumbuck 09-18-2012 10:23 PM

Hey Alan ,

I just had a thought...
I use linux ubuntu as my primary OS but also have win7 installed (dual boot), anyway I booted into windows and neither swissknife or My Computer shows the windows recovery partition. Its a 25Gb FAT32 partition on my laptop.
I downloaded FAT32 formatter and it showed it as does the linux gparted program. You can download Fat32formatter from here Fat32Formatter
If the windows recovery partition is still on the drive then it'd probably cause you dramas when your player tries to boot from it. So I'd give Fat32 formatter a go and see if you can delete any and all partitions and then format the whole drive as a fat32.
All the best


powysa 09-22-2012 09:03 AM

Hi Garry,
The drive is definitely not an Apple one, but I did the full format to Windows ntfs, then used Fat32fFormatter, which worked perfectly, so drive is correctly Fat32 formatted.
The H340 still doesn't boot it up though.
When the machine's up and running without the hard drive recognised, and I briefly press the NAVI button, it comes up with a single folder with strange Eastern (Korean?) characters identifying it. It then refuses to do anything else or come out of this menu except by turning off the machine or pressing the reset button. It does seem that it's the machine's firmware that is somehow at fault...?

This advises transferring the appropriate H300.hex file to the (unrecognised) drive then upgrading the firmware, so after getting what I think is the right file from http://rasher.dk/rockbox/iriver-firmwares/, I went into the General Menu and requested Firmware Upgrade - and the machine just ignored the request. But surely as it doesn't recognise the drive, this is indeed the likely outcome of this procedure...? Shades of Catch 22?
Yet I know of no other way of changing the firmware. The iriver site is useless; its H340 firmware upgrade download is dated Dec 2005 and now leads nowhere.
Hey ho. Thanks again for your suggestions.

jumbuck 09-22-2012 05:23 PM

Hey again Alan :-)

Did you see my last post about the hidden windows recovery partition? [quote=jumbuck;621650]
I'm thinking that if the recovery partition is set as the primary drive your player may have problems recognizing it as a bootable partition.
Try formatting with Fat32Formatter you may have to delete all partitions and then create your new FAT32 system.

If this doesn't work what I'll do is to try to format a drive so it comes out as to simulate a 2nd hand windows drive with the windows hidden partition and a separate fat 32 partition and see if I can replicate you problem and then possibly solve it.

The only time I recall seeing "strange Eastern (Korean?) characters" is when I once (a looong time ago) disconnected my player while I was transferring music which resulted in corrupt files which the player couldn't recognize. But a format and possibly a windows check disc fixed that.
Again I'm thinking there may be a separate hidden partition on your drive.

You shouldn't need to upgrade the firmware to get the drive recognized as the iriver firmware is stored on th eeprom chip in your player. If you are running rockbox you'll need the .rockbox on the root of your player to boot to rockbox but the bootloader will boot to iriver firmware by default if the folder is not present.

powysa 10-31-2012 06:33 AM

Hi again - apologies for delay. Did the Fat32Formatter format as advised (twice in fact, deleting/initializing each time). Worked fine, but no joy.

Fat32Formatter does not show any recovery partition at all for the player's HD, only 74.52GB main partition. But it does show my laptop HD's recovery partition (11.72GB). Win 7 Computer Management shows exactly the same partition info.

So player HD recovery partition doesn't appear to exist - is this possible (all this is beyond my normal knowledge zone - sorry).


jumbuck 11-04-2012 01:38 PM

Hi Allan,
Well I'm at a loss as to what else to try.
I checked on my player and have the same partition sizes as you.
I had a big google for a solution or similar problem to yours but came up empty handed. I did find one thread on rockbox (but it was yours LOL) and I take it you've tried their suggestion.

Out of curiosity....
I noticed in your first post that you mentioned you have a similar player from which the drive works in your H340. Have you tried the MK8007GAH drive in that player to see if it'll work in that?

If I find any thing else out I'll post back here with a link or something.

powysa 11-07-2012 01:03 PM

The original 40GB HD from my 1st player works in both players. The newer 80GB HD does not work in either. Therefore, despite it not being an Apple model, and despite other people having been able to upgrade to 80GB with no/few probs, this HD must for some strange reason not be compatible :(

Having said that I've just logged on to the Rockbox site for the 1st time in ages, and noticed the response you referred to. I'm pretty sure I've done this procedure at some point in the last 3 months, but will do so again just in case...and will let the world know if successful!

Cheers, Alan.

almo88 11-26-2012 11:11 AM

I have the same problem : except the problem started when I changed the battery.

The Drive I have is 60GB, about 2 years old, and was working fine up to a few days ago, when i attempted to replace the battery. It doesn't seem like the hard drive is being even powered (No mechanical noise).

I suspect I damaged something during the upgrade. I no longer have the old hard drive for reference.

Any suggestion as to what I might try?

jumbuck 11-28-2012 02:09 PM

Hi Almo88,
Check you haven't dislodged (or damaged) the ribbon cable from the main board. IIRC there is a bit on the board connector that you pull up which will release the ribbon and clip down to hold it in place.

Kubicixfactor 11-30-2012 07:29 AM

I had a similar problem.

You need to format the drive as fat32, and most important set the partition as active. Make sure you copy the .h300.hex file to the root.

almo88 12-01-2012 08:07 AM

Thank you for the advice.

As far as I can tell - the HD connector is in place - it is solidly in place with no freedom of movement that I can discern.

Although I have no easy way of connecting the HD to another computer to verify this, I do not think the problem is in the HD formatting. Two reasons for that :

1. The HD worked fine right up to the moment I opened the unit to replace the battery.
2. I do not get any motor sounds from the HD when I power up the unit. This suggests to me that the HD is not receiving any power, or it is fundamentally damaged and doesn't "turn on" when power is first applied.

It is difficult to reach the lower side of the PCB. Is it possible I cause the problem when partially lifting the PCB to access the Battery connector?

Thank you for all the advice!

KennyRocks 01-09-2014 06:18 PM

I am having this exact same problem.
I dropped my H320 and bust the HDD so I ordered a replacement. Fitted it and it keeps saying Check HDD Connection. I also see no damage to the motherboard or ribbon.
I have tried to change HDD's on 2 seperate players now and it happens on both. very strange.If I find a solution I will post.

All times are GMT -5. The time now is 05:38 AM.