abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Clip / Clip+ / Clip Zip (http://www.anythingbutipod.com/forum/forumdisplay.php?f=119)
-   -   Clip+ memory reading problems and radio noise increases (http://www.anythingbutipod.com/forum/showthread.php?t=70209)

Kamiocandy 08-05-2012 02:54 AM

Clip+ memory reading problems and radio noise increases
 
Hi everyone,

I have a Sansa Clip+ 4GB, a replacement for my earlier one which lost signal in one headphone channel and its clip.

- Problem 1:

When I boot it into Rockbox, it often doesn't seem to recognize the internal memory, as it doesn't find the .rockbox directory and does not find any other files, either. If I then plug in the USB cable it starts to charge, but when I unplug it again it results in a kernel panic.

When I take out the muSD card, the problem is fixed temporarily, even with the card back in, but after a while it picks up again.

In the same "problem phase", under the regular firmware it often can not read the muSD card. When I unplug it after charging, it freezes for a while, before showing the menus or the "media library updating" status bar. A while ago, it also used to freeze for quite a while reading from the muSD card, although not failing completely (so that playback might start after a while, but be interrupted shortly after).

- Problem 2:

When I listen to the radio, the noise increases with time, so the sound goes from crystal clear to unintelligible over the course of half an hour or so. When I retune the radio when it is noisy, that is tune away and then back to the original frequency, I'm back at the beginning with clear sound.

What's the matter? As I listen to the player to fall asleep, it has been uncharged a few times, and also lain on in a sweaty bed.

Kind regards,
K

Edit: Combined both questions into a single post.

skip252 08-05-2012 03:50 AM

I've placed your two threads together. It's one player with multiple problems so there's no sense in multiple threads.

If it's not reading the card properly in either Rockbox or the OF it would seem to be a hardware problem. You could try a different card to see if that's the source of the problem. I wonder if the repeated contact with moisture may be causing an internal problem with corrosion. I'm careful to keep mine dry so I haven't had to check on that before. Someone may have some ideas on how to deal with that possibility.

I've no idea on the radio noise problem. I only use mine long enough to get weather updates and don't have any problems in the ten minutes or so that usually takes. Is that also a problem with both Rockbox and in the sandisk firmware?

BTW if you're reporting a problem with Rockbox it's best to report which build you're using. If it's the release version you'll want to update to a development build. There's always a possibility one of the dozens of updates added since the release fixes your problem.

Kamiocandy 08-05-2012 04:46 AM

I'm sorry, I thought that different problems warranted different threads.

Yes, the radio problem doesn't depend on firmware. My Rockbox version is 3.11.2, but they don't seem to be Rockbox problems. I was wondering whether someone knew these specific problems and their origin.

Tapeworm 08-05-2012 12:25 PM

Quote:

Originally Posted by Kamiocandy (Post 618243)

When I listen to the radio, the noise increases with time, so the sound goes from crystal clear to unintelligible over the course of half an hour or so. When I retune the radio when it is noisy, that is tune away and then back to the original frequency, I'm back at the beginning with clear sound.

What's the matter?

There is a known "station drift" problem with some Clip+'s. There are (as I understand it) 2 different FM chips that were used. One has the problem; the other doesn't. Sounds like you got one of the undesirable ones.

And before you ask, there is no way of outwardly telling which one is inside the player you may currently be holding, so if you're thinking about getting another one and wanting to determine which FM chip is inside beforehand to avoid the issue, forget it.


All times are GMT -5. The time now is 07:52 AM.