abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa e200 Rockbox (http://www.anythingbutipod.com/forum/forumdisplay.php?f=72)
-   -   Rockbox for e280R (http://www.anythingbutipod.com/forum/showthread.php?t=68022)

mlmertes 02-09-2012 12:29 PM

Rockbox for e280R
 
Hey guys, New to the forum. I've looked around most of the day and saw that people have put rockbox on their e280R. I've working with modding and tampering things before so I thought "This Should Be Easy". So I started following the directions of rockbox, but when I try to use the drivers supplied by the site I couldn't get windows 7 to change them. It says: "the folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work for windows 32 bit systems.

Any ideas on what to do? Hopefully i didn't miss this somewhere in the forums. Thanks ahead of time for any help and advice.

-Matt

WalkGood 02-09-2012 01:01 PM

From your description I'm not sure what you're doing but is the e280 connected in msc mode and is it recognized by your pc? I only ask this as many connect as is and it's in mtp mode, which won't work.

Edit: BTW I don't have an "R" series but do have a e260 that's rockboxed, did it the manual method from the rockbox manual many moons ago. I do know that there's someone in abi irc that has the "R" series rockboxed (advcomp), he's here too but he might be easier to get a hold of in irc.

mlmertes 02-09-2012 01:12 PM

Quote:

Originally Posted by WalkGood (Post 598214)
From your description I'm not sure what you're doing but is the e280 connected in msc mode and is it recognized by your pc? I only as this as many connect as is and it's in mtp mode, which won't work.

It should be in msc mode because the wheel is lit. When I try to run the patch is says "Could not find any usb busses". When I start the instructions using the patch, and I plug in the 280 i get a weird sound. Its like the computer detected it, but its not working properly.

This is step by step what I did.

Powered off my device.
Slid hold mode ON.
Held select key down and plugged in usb cable.
Held select key down for 10 seconds.
Ran patch.
Err "Could not find any usb busses."

WalkGood 02-09-2012 01:26 PM

Are these the instructions that you are following? Should work fine, but I don't have the R to test that as mine's the v1 model. If it's the driver that's missing, I believe they're on WMP from ed 10 or 11 up.

Edit: those instructions do have the driver i see, so no need for wmp

mlmertes 02-09-2012 01:44 PM

Yep, those are the instructions i'm using, and I do have WMP 11. Maybe because its R I have to do something else? maybe i should try running the patch in compatibility mode to see if that helps.

WalkGood 02-09-2012 01:49 PM

Not sure what to tell you, I know someone that did it from xp but it should work on your system. Did you unzip the driver, did you point it to the folder you extracted the driver zip file? That's all I can think of as I don't run win7. It wouldn't hurt to try what you said running the patch in compatibility mode ...

mlmertes 02-09-2012 01:54 PM

yes i did that and pointed them there. thats when i got the error from my first post. It said it wasn't a compatible driver if the folder had a driver make sure its compatible with windows 32-system. I even made sure it wasnt pointing at the 64bit file and i still got the same error.

WalkGood 02-09-2012 01:57 PM

If it doesn't run/work in compatibility mode do you have a friend that might still be running xp would be my only other thought.

Edit: I'm not sure if this would work but another thought would be: IIRC, there's a method to change a "R" series player into a regular e200 (I don't know the link but you might want to look in our e200 forums). After you convert it, and again I don't know this to be correct, you could try installing rockbox like a regular e200 series player.

Edit2: I gave advcomp2019 a heads up in IRC but he doesn't seem to be around, but as I stated before he does have an "R" series rockboxed e200 player, he should be able to help more than me.

mlmertes 02-09-2012 02:03 PM

I just got the driver to install. In the words of my brother (and why i will follow in his footsteps of IT) reboot your computer. Sure enough it worked. im ready to scream. Now lets see if it works the rest of the way.

WalkGood 02-09-2012 02:04 PM

Nice, good luck :)

mlmertes 02-09-2012 03:06 PM

Okay, got all the way through the installation and at the restart i get the following error...


Can't Load rockbox.mi4
File not found

Noticed in another thread that someone had the same problem back in 07. So i checked and sure enough the file folder name is .rockbox

Backed into a corner again.

Edit: Trying the v2 download, think I used v1 before...

saratoga 02-09-2012 03:18 PM

Quote:

Originally Posted by mlmertes (Post 598238)
Okay, got all the way through the installation and at the restart i get the following error...


Can't Load rockbox.mi4
File not found

Is there a rockbox.mi4 in your .rockbox folder?

Quote:

Originally Posted by mlmertes (Post 598238)
Edit: Trying the v2 download, think I used v1 before...

You think *think*? Its kind of important that you use the correct files. And no, you have a v1, so do not try the v2 software.

mlmertes 02-09-2012 03:35 PM

Okay... I got it. I extracted the files again and this time it booted up. I appreciate your help! We can close this thread up. I'll be sticking around. next i'm going to learn themes! Once again, thanks for your help and quick replies. It means alot.


All times are GMT -5. The time now is 04:38 AM.