abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Headphone Amplifiers (Portable) (http://www.anythingbutipod.com/forum/forumdisplay.php?f=189)
-   -   iBasso T5 (http://www.anythingbutipod.com/forum/showthread.php?t=66654)

bennyboy 11-23-2011 06:55 AM

iBasso T5
 
Anyone tried one of these babies yet?

http://www.ibasso.com/en/products/show.asp?ID=75

Guess the balanced ground is designed to put it head to head with the Corda Stepdance / Stepdance 2? Is it likely to have much impact on perceived sound quality?

bennyboy 11-29-2011 02:36 AM

My T5 arrived today.

First impressions, before even using: it's so tiny! Bloody hell is it tiny.

bennyboy 11-29-2011 07:05 AM

Second impressions: it works really well.

But since ordering it, I've decided I'm going to upgrade my headsphones, so need the cash that a quick sale will offer.

So, if you want a brand new - used for less than 1 hour - iBasso T5, at a superduper bargain price, click here: http://anythingbutipod.com/forum/sho...238#post586238

The DarkSide 12-03-2011 04:40 PM

I'll be finding out how good it is soon enough,...I'm quite anxious to see if it works as well as claimed.

The DarkSide 12-07-2011 05:29 PM

It's good, and it's LOUD!!! I find the Digizoid ZO has better bass though - and the claims of the caps "burning in" are ridiculous. Still, quite good for an audio buff looking for clean sounding amping,...I like it quite a lot. Plus, I don't hear static with my Sony MDR-V900HD's like I've heard with some of the other "cheap-o" amps I've had (FiiO E3, PAVA2, even the Digizoid Zo).

I do have 2 issues so far: First, it's makes quite a bit of noise & static when you turn it off,...annoying but not a deal breaker. Second, the volume seems to reset after you turn it off. That means I have to readjust it every time I power off & back on again. Annoying, but not major. This is actually a hearing saving feature IMO, as I switched between this & the ZO and nearly had my ears bleed!!! No a good feeling,...

Overall it's quite a nice device,...I'll be testing the SQ over the next few days - Thanks BennyBoy!!!

WalkGood 12-07-2011 07:50 PM

Quote:

Originally Posted by The DarkSide (Post 587635)
... I do have 2 issues so far: First, it's makes quite a bit of noise & static when you turn it off,...annoying but not a deal breaker.

This could possibly be the digital volume control causing it, but it shouldn't be an issue once you have the volume set, if its a big bother I'd contact iBasso as I'm sure they'd take care of it. On my pico slim (also has digital pots) that isn't an issue, it's only the power on/off "pop" sound it produces which I found out if you power on before plugging in sensitive IEMs then it's eliminated. BTW if it's not the pots could be the gain switch, do you have it on the correct setting to better match the phones impedance? If it's not either, it could be the big power that little thing produces ;)

Quote:

Originally Posted by The DarkSide (Post 587635)
Second, the volume seems to reset after you turn it off. That means I have to readjust it every time I power off & back on again. Annoying, but not major.

A feature I actually really liked on the prototype pico slim which was later removed from the production slim that I didn't find out till I received mine :/ The implementation on it was if someone started talking to you, you could just power off the device and later when you turned it on, it would slowly work its way back to the volume level you had it at (like a fade off but was fade on). Not sure if that is what you were describing ...

Quote:

Originally Posted by The DarkSide (Post 587635)
Overall it's quite a nice device,...I'll be testing the SQ over the next few days ...

Congrats and enjoy, let us know more as you get acquainted with her :)

The DarkSide 12-08-2011 05:28 PM

Well, I used it last night with my ath-pro700mk2's and I discovered something. This really IS a neutral amp. No bass enhancement, no mid or highs being altered,...it's just a clean boost. I even used my EQ setting for the cans and the SQ was fantastic. And the volume thing is a non-issue I guess. I'll just see if it creates a problem and act accordingly.

And, the phones I'm using are quite sensitive (ath-pro700mk2's), so I have the gain set to low - I really don't need a mega-power boost. I personally just want enough power to the HP's to have the output unrestrained or restricted (I guess that's how you'd phrase it,...).

I might even opt for the Bayer Dynamic DT770 80 ohm now,...I think it's child's play for THIS little amp.

Oh, BTW - the Sony MDR-V900HD is friggin' BRILLIANT with this amp!!! I was TOTALLY AMAZED!!!

WalkGood 12-08-2011 05:57 PM

Nice to hear you're enjoying :) and if you think the sony's are brilliant, just wait till you hear the DT770 :p

The DarkSide 12-08-2011 06:34 PM

Thanks WG - I can't wait!!! :cool:

WalkGood 12-08-2011 06:56 PM

Sounds like they could be on the way ;)

Marvin the Martian 12-08-2011 06:59 PM

Quote:

Originally Posted by The DarkSide (Post 587838)
Thanks WG - I can't wait!!! :cool:

So much for 6 months of no new gear! :p:D

The DarkSide 12-08-2011 08:37 PM

Quote:

Originally Posted by WalkGood (Post 587842)
Sounds like they could be on the way ;)

Quote:

Originally Posted by Marvin the Martian (Post 587843)
So much for 6 months of no new gear! :p:D

No guys, I didn't order the DT770's yet,...I'm still enjoying my pro700mk2's too much. Maybe next year,...;)

WalkGood 12-09-2011 04:43 AM

Quote:

Originally Posted by The DarkSide (Post 587858)
No guys, I didn't order the DT770's yet,...I'm still enjoying my pro700mk2's too much. Maybe next year,...;)

Key word I read is "yet" and next year is is only 23 days away ;)

The DarkSide 12-09-2011 02:59 PM

Yup, 23 days to go,... :D


All times are GMT -5. The time now is 01:47 AM.