abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Zen Touch 2 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=252)
-   -   Rooting the creative zen touch 2 for market support (http://www.anythingbutipod.com/forum/showthread.php?t=65489)

EarthwormDan 09-09-2011 06:18 PM

Rooting the creative zen touch 2 for market support
 
I found this article while searching for a way to enable android market support...

http://translate.googleusercontent.c...kPcvvqz9q801jQ

It is translated from japanese (i think) but having never owned, let alone rooted an android device I am a little cautious about just jumping in and following some translated steps in broken english, I'd hate to brick my latest toy after all!

Now from what I gather, this guy has managed to root the zen touch 2 and enable android market support so I figured you guys would at least be interested in reading over his steps.

Now ideally someone with some knowledge of rooting android devices wouldn't find this page quite so foreign and I would be forever in this persons debt if they could explain things a little clearer for me, maybe post a guide here or something!!

Market support would make this mp4 player an amazing little toy, Other than this small oversight I really can't fault it. Hope someone can help me here.

EarthwormDan 09-12-2011 11:34 AM

Ok well slight update, someone from the board contacted me via email saying that the app 'UniversalAndroot-1.6.2-beta5.apk' will root the zen touch 2... he didn't go into much detail though, and I suspect that doesn't help with enabling the android market which is what I want to achieve.

Has anyone with experience of rooting & modifying the android-os had a chance to look over the japanese blog I linked to?

really hoping I can get the ball rolling here, kinda put all the needed infomation in one place!

Please post here in future so the infomation is out in public, I want to help everyone not just myself :D

FearTheNoFear 09-14-2011 11:31 PM

I would be interested in rooting my zen as well. I know it has a Cotrtex A8 processor. I would also like android app store access as well as these bugs resolved. Like music plays the last couple seconds again even with different music players. I registered on slatedroid and they have forums sorted by processors. I'll try posting something there and I can let you know. This is the first thing I've seen for the touch 2 about rooting it. I've never rooted before either. Sorry if this sounds weird. Typing on the zen is still bit weird for me.

ryan49ryan 09-27-2011 03:59 PM

Android Market on the Zen Touch 2
 
1 Attachment(s)
Installing the android market on the Zen Touch 2

All files needed are included in the zip that can be downloaded from the attachment or this link:
http://dl.dropbox.com/u/24314265/apps_required.zip
Just unzip it to your Zen's SD card.

I got this method to work after messing around with my Zen for most of the night. The steps are what I think made the whole thing work out, but I may have done something else that caused this to work. If you can't get this to work PLEASE post a reply and I will post the whole process that I went through.

1. Install "z4root.1.3.0.apk".

2. Open Z4root and click permanent root, it will take a bit to complete, then it will restart your Zen.

3. Now install "Root Explorer 2.16.apk".

4. Copy the "com.android.vending-1.apk" to your SD card.

5. In Root Explorer the file "com.android.vending-1.apk" and long press it, select copy then navigate to the root directory by pressing the back button until you see a single "/" as the directory at the top under the notifications bar.Then navigate to /system/app, then at the top there should be a button that says "Mount R/W", press it and it should now say Mount R/O, now tap paste at the bottom.

6. Click on the "com.android.vending-1.apk" and tap install. Once it is installed DO NOT OPEN/RUN IT!

7. Restart your Zen and then wait for everything to load up.

8. There should now be an icon for the market in the app drawer. Open it and you should be prompted to add your Google account, type in your Gmail address and password, YouTube or any other Google service you have an account for.

9. You now should have the working android market on you zen touch 2!

Paawit 09-29-2011 02:09 PM

To ryan49ryan,

Thank you for your post that I'm looking for it for a month.

I did what you post and now it's showed market icon, but when I want to click yes to add my gmail account, it keep shutdown.

So maybe you have some more steps for make it work?

Thank you

ryan49ryan 09-30-2011 09:06 AM

Paawit,
Do you get far enough that you are able to enter your Google account information into the market app?

Paawit 09-30-2011 01:23 PM

Quote:

Originally Posted by ryan49ryan (Post 577502)
Paawit,
Do you get far enough that you are able to enter your Google account information into the market app?

no, I've reach "You must add an account to the device to continue.Do you want to add one now"
and then when I clicked yes the market close immediately. So I can not use market yet.:(

ryan49ryan 09-30-2011 06:32 PM

Try going to Settings > accounts & sync Settings, then try and add your google account. Then restart your Zen.
If that doesn't work try unzipping this file "app_s.zip" , to your sdcard. Then copy all of the apps over to the "system/app" directory. Install "OneTimeInitializer.apk" and "setupwizard.apk". Restart your zen and It will say that one of them has crashed, tap "OK". It will come up again, keep tapping ok until it stop. Then delete it from the system/app file.Restart and the market should work.
If none of these work please reply and I will try again to help you.

Paawit 10-01-2011 12:16 PM

Now I have some big problem.
I did what you said but now my zen don't work anymore after I install setupwizard.apk and rebooted
it's show
△! Sorry!
The application Setup Info (process com.android.setupwizard) has stopped unexpectedly. Please try again.
I stuck on this screen, what can I do next?

Paawit 10-01-2011 01:09 PM

Sorry I posted the last one too fast now my market work really well, and now I knew why i can not install some apps when i downloaded it in apk file. because they're for android 2.3.

Thank you very much to you
ryan49ryan

ryan49ryan 10-02-2011 08:33 AM

I'm glad to hear someone finally got the market to work:)
What did you do to make the notification that says:
"△! Sorry!

The application Setup Info (process com.android.setupwizard) has stopped unexpectedly."
How did you make it stop coming up repeatedly? I just kept tapping ok until it stopped, did you do anything different
Paawit?

Paawit 10-02-2011 09:13 AM

Quote:

Originally Posted by ryan49ryan (Post 577788)
I'm glad to hear someone finally got the market to work:)
What did you do to make the notification that says:
"△! Sorry!

The application Setup Info (process com.android.setupwizard) has stopped unexpectedly."
How did you make it stop coming up repeatedly? I just kept tapping ok until it stopped, did you do anything different
Paawit?

I did keep tapping and restart many time and also reset factory setting and again keep tapping.
But I thing you don't have to do factory reset. oh i also do tried to update firmware by "update.zip" But it's not work.
And when I go to market many apps said "Your device is not compatible with this item", is it happen to you also?

and I wonder "Verizon Motorola DROID X Software Update" that do it really work to upgrade to 2.3?

Ps. Don't update Market.

gazoo 10-12-2011 12:30 PM

Hi there!

I've registered on this forum just to ask for a help on this case. I was following the instructions from above but I can't get past the initial dialog as already mentioned here:

"△! Sorry!
The application Setup Info (process com.android.setupwizard) has stopped unexpectedly. Please try again."

Several reboots (at least 15), several resets and tens of confirmations for the error message window.

Any idea, what should I do, please?

Kind regards,
Bernard

framerrocky 10-18-2011 02:41 PM

When I try to install the OneTimeInitializer.apk it says "There is a problem parsing the package." After that I hit OK and it closes. Any ideas? I have tried with and without Debugging Mode.

ryan49ryan 10-20-2011 03:56 PM

It seems that the file is corrupt. Try downloading the file again and unzip it to your sd. If it still doesn't work I will post the file again.

gazoo 11-02-2011 01:29 PM

Ok, so at least for the case somebody will get stuck at the same situation as I was.

When you keep tapping "Force Close" to the pop-up messages and you don't seem to be getting anywhere, it's the time to boot into the recovery console.

1) Turn your Zen Touch 2 off completely
2) Start your device by holding both the power and the home button at the same time. Until the recovery mode jumps in.
3) From the recovery menu select option 3 (navigate with volume buttons, confirm with home)
4) Confirm

After that your device will be completely erased from the user data and brought back to the factory default settings.

So I get this Set Up Your Device dialogue. I fill in my email address, but still no chance to move forward. The error message comes again and again.

Any help would be deeply appreciated. Even crazy ideas as well ;-)

Kind regards,
Bernard

gazoo 11-04-2011 12:45 PM

Some light at the end of the tunnel.

They direction in which I'm thinking currently is to prepare the update.zip file to restore the OS completely. For that I've downloaded the firmware update package (apk) and extracted it like a standard zip. Within the folder "assets" there's a file called "data". This file is also an archive which follows the rules for "update.zip" for recovery console usage.

But renaming the "data" file to "update.zip" and loading it from the SD card via the recovery console on the device, I get the message that signature verifying failed. That is weird, because when I try to check the signature with jarsigner tool on the PC, it says that the signature is valid and verified.

Any idea here how to move forward, please?

Thanks.
Bernard

ryan49ryan 11-04-2011 08:06 PM

Try booting in to the recovery menu and selecting the 4th option which says "wipe cache partition". That should allow you to boot up and have the initializer start and not have any other conflicting information that was already entered. I don't know if this will work because I didn't have to do this when I got the market working. All I did was click ok while trying to get to the shut-down dialogue. I shut it rebooted and the market worked, It seems strange how it works so badly for many other people.Good luck Ryan

MukiChan 11-08-2011 07:31 PM

I'm having the same problem Paawit had where the Market application crashes right after I click to add the google account.

However, when I try your first solution, adding the google account under settings>accounts & sync, I am unable to add an account there either. I get the error message "setup could not finish unable to open connection to server." I am, however, able to add the same e-mail account under the e-mail application.

Just to be clear it is connected to WiFi and I have no problems browsing the internet, so it is not a network issue.

Thanks to Ryan49Ryan for posting the info and getting me this far, if nothing else I will walk away with root access, but market support would severely help un-nerf what should be a nice little linux handheld.

MukiChan 11-08-2011 09:25 PM

So.....I tried Ryan's app_s collection, but I wasn't able to copy all of the files over as only about 6 mb of space were allocated for /system . I tried to run OneTimeInitializer.apk anyways - probably a mistake - it said the installation could not be completed. After exiting Root explorer and rebooting, though, my home screen is no longer available. Instead my homescreen is "Welcome to Maple." It says to touch the Android logo to continue, but this does not work. I managed to get it to work once, but it merely said that setupwizard had stopped unexpectedly. I have tried all of the recovery console options but no luck, so for now the thing is pretty bricked. Any ideas of how I could restore it?

I have tried to some extent following what gazoo was doing, however the recovery console says "E:Can't mount EXTSD:update.zip" when I try the 'apply sdcard:update.zip' option, even before adding the custom update.zip file. I have extracted the data file from the firmware and renamed it to update.zip as well, but I am not sure where to put it. Not surprisingly, placing it in /sdcard did not yield any better results. I'm trying to get adb.exe (from the Android SDK) - or another program if someone knows of one - to recongize my device so I can access the root directory via USB, as I'm guessing I would need to put the update.zip somewhere in there.


All times are GMT -5. The time now is 10:15 PM.