abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Samsung R0 / Q3 / Z3 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=213)
-   -   aac files take ages to start on Ro. Why? (http://www.anythingbutipod.com/forum/showthread.php?t=58015)

Nethersage 10-01-2010 03:37 PM

aac files take ages to start on Ro. Why?
 
Hi, I'm a total newcomer to the Ro, and these boards.

I took advantage of the recent experimental trials of 320kbps aac audio for the last week of the Proms on BBC Radio 3 to use suitable software to download a few to test. The files were wrapped up in flv files from which I extracted them with FLVExtract.exe. Once loaded onto the Ro (firmware version 1.10 or 1.22) they do eventually play, (well, sometimes they don't and the dreaded system check and restart ensues), but only after about 60 seconds of inaction. The files are fairly large (in the order of 250MB) but should they really be taking that long to start?

Oh, and I haven't tried yet but does anyone know if the Ro can be tricked into playing mp2 files by renaming the suffix as mp3? Perhaps I should just give it a try.

[Update: So far so good with renaming mp2 files as mp3. The test 192kbps (48khz sample rate) file from BBC Radio 3 DAB is playing well. However, it's a bit early to be sure. In my experience of other players on which I have tried this work-round, after some time horrible bursts of digital artefacts in the form of loud 'cracks' or 'squeaks' manifest themselves. I'll report back.]

saratoga 10-01-2010 04:15 PM

You might want to try repacking the AAC files into a new MP4 container. Something like mp4 box or foobar2000 might be able to do it. The reason I suggest this is that MP4 is a weird container that supports all kinds of really inefficient layouts for audio files, some of which can be extremely slow to decode if the file is very large. If the file started out as an FLV it might be packed into a really weird MP4 file and thus have these issues.

Nethersage 10-01-2010 04:33 PM

Thanks for that, saratoga. I will try to investigate.

The the mp2 renamed as mp3 is still going strong without any unwanted interruptions, or loud reports. Since it has now been playing for some 40 minutes, I think the Ro might just have come up trumps.


All times are GMT -5. The time now is 08:38 AM.