abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Samsung R0 / Q3 / Z3 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=213)
-   -   Samsung YP-R0 - can not open file (flac) (http://www.anythingbutipod.com/forum/showthread.php?t=57906)

vian 09-26-2010 03:43 PM

Samsung YP-R0 - can not open file (flac)
 
Hi everybody. I've just recently bought this player. Everything was working fine since today.. I am getting a "Can not open file" error message while trying to play a flac album. The strange thing is that the same flac album was working fine yesterday.

Other flac files (and everything else) works fine (actually I only have this album + 1 more showing up the error - both flac).
Both albums were tagged with linux easy tag, I am sure the files are not damaged, they works fine on my laptop. I tried to re-tag the files, delete and upload them again - still the same.

Could the problem be that I updated the firmware from 1.17 to the latest 1.22?

Am I missing something, or doing something wrong? Is there anything special about handling flac files on this player? I tried to google and also checked this forum but no luck :( I will appreciate any advice how to get it sorted. Thank you.

lebellium 09-26-2010 03:52 PM

I guess you should read the other threads here and also the firmware changelogs here: http://www.anythingbutipod.com/forum...ad.php?t=32690

Your firmware is dangerous, you have to know that. And please set your R0 in MSC mode.

vian 09-26-2010 04:09 PM

Thanks for the quick reply, labellium. I thought that the 1.22 firmware is safe (as it is the latest one). I downloaded and installed it from the link you gave me. Do you recommend a different one? The player is set to MSC mode all the time.

But there's an update: I deleted the affected flac files from the player and uploaded them again from my backup disk (not tagged with easytag) and it works ok again (but only for the album that was working yesterday, the second one still gives the error).

rohit3192 09-26-2010 04:41 PM

I think labellium mistook your firmware to be 1.17 whereas you have mentioned that you have"updated"to 1.22.
1.22 is safe.

lebellium 09-26-2010 04:46 PM

Hmm scuse me. I thought you were in fw 1.17 indeed.
Yes, fw 1.22 and 1.10 are the safiest although no one can be considered as 100% safe unfortunately.
Could you send me a FLAC file unsupported? If this is a real bug I can report it to Samsung ;)

ochie 09-26-2010 08:57 PM

Could you send me a FLAC file unsupported too?
My Email: yopi_suhendi******.co.id

vian 09-27-2010 01:45 AM

Good morning, guys :) One more thing you should know about the unsupported flac files: they were extracted from one big flac file (I downloaded it from the net) with attached .cue file. I extracted separate files using cuetools and tagged them using easytag:

cuebreakpoints sample.cue | shnsplit -o flac sample.flac

So IMHO the player is either not able to play some flac files tagged with easytag, or files splitted by the cubebreakpoints command.

For those interesting in this issue I uploaded one of the flacs (I do not want to email it, it is a relatively big file):

flac download

UPDATE: Well.. so I deleted all the tags (but track numbers) created by easytag and it works! I do not know what exactly was wrong (I never had any problems with tagging) but if I find anything, I will let you know.


All times are GMT -5. The time now is 06:54 AM.