abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa e200 Rockbox (http://www.anythingbutipod.com/forum/forumdisplay.php?f=72)
-   -   Help me get my sansa e260 back to running! Is it Bricked? (http://www.anythingbutipod.com/forum/showthread.php?t=57357)

Sansa-E260RockBoxed 09-02-2010 03:35 AM

Help me get my sansa e260 back to running! Is it Bricked?
I installed Rockbox about 8 months ago and have been using it with no problems, until now. It’s a Sansa e260 version 01.00.12A ***Please Help.***

I am using the iPhone’s wall charger with the USB connector on top which works great, I have been using it for the last 6 months or so with no issues, it even lets me listen to music while charging. Which it didn’t before Rockbox.
Well, to the issue, Yesterday I needed to charge my e260 and couldn’t find the iPhone adapter so I decided to connect it to my Xbox360’s USB port since the voltage output is the same as the iphone’s adapter (5v - 1A) when I connected it only the “Rockbox logo, Version 6.0” showed up, which was kind of odd since it usually shows the USB connector plug in the screen too, showing it’s connected.
After this happened, I can’t get it to work I tried connecting to the computer, but it doesn’t “sense” it, so I can’t look at the USB drives.
The same screen comes on every time I try to reboot it.

When I turn it on this is what happens: San Disk logo, than the Rockbox logo comes up and version 6.0 on the bottom of screen. When I try to boot it into Sansa’s firmware using the left button while pressing the power at the same time and it displays the San Disk logo, then to a black screen saying:
Rockbox boot loader
Version 6.0
Sandisk Sansa e200 series

It stays there until I press the power button 10 long secs. until it finally shuts off.

Please help!
I already took it apart to see if anything was loose, I also made sure to press down on the foam for the chip above the battery, and nothing.
Is this now considered Bricked? I already tried going into recovery mode which it does, but I'm afraid to mess with this since I'm not experienced enough. Plus I don't know if this was the right thing to do next.

WalkGood 09-02-2010 06:15 AM

Per your description at this point you have nothing to lose, so you might as well give the e200tool a shot. Look here for recovery guide and good luck.

Sansa-E260RockBoxed 09-02-2010 11:26 PM

Thanks for the reply, Is that my only option? I looked trough that guide but when it starts talking about Operating systems and BIOS settings I get kind of erie. I'm not familiar with messing with operating systems and such.
I read something about fixing it though the e260 sansa's "recovery mode" could that be an option for me? I am able to get it to go into it. When I tried it said "welcome to recovery mode" connect USB to computer" I think. But I wouldn't know what to do from there neither....
Please Help!!!

WalkGood 09-03-2010 05:55 AM

AFAIK the e200tool is the only option, in order to connect it and use the e200tool you do have to get it into the recovery mode and use Linux. If you can't follow the instructions it might not be for you, you could donate it to the rockbox team or sell for parts on ebay ...

Sansa-E260RockBoxed 09-11-2010 01:35 AM

I did some thinking, and I'm going to try to unbrick the ol' e260. I was worried about mesing up my PC, but luckily I have an extra older one which is running windows 98.
I hope all goes well.
Do you know where I can get the e200tool? I went on that site's recommendation but I don't see it, is it by chance the link named "v0.2.3 Source code" and which are the appropiate files for the e260 version 1 I think the link the guy who wrote the guide gives is for the e250 files.
Thanks for all the help.

WalkGood 09-11-2010 07:05 AM


Originally Posted by Sansa-E260RockBoxed (Post 498644)
... Do you know where I can get the e200tool? ...

the links near the top on the tutorial for daniel's page http://daniel.haxx.se/sansa/e200tool.html

Sansa-E260RockBoxed 10-21-2010 04:02 AM

I ended up using the "recovery mode" rather than the e200tool on Linux. It seemed easier this way and wanted to try it first.

I got it working, but Where Did My ROCKBOX Go?
After doing some more reading and searching for the appropiate .mi4 file for my sansa e260 v1 (which was PP5022.mi4 - I got it from the sandisk website) I finally tried to unbrick my e260, I went into recovery mode, and pasted a copy of the PP5022.mi4 file in the 16MG drive. It worked (w/some glitches here and there) but It works again.
The computer wouldn't recognize it at first, it was at the time on MTP mode by default so I changed it to MSC and it recognized it this way. It works on factory OF but it doesn't boot into rockbox anymore. Now am I supposed to uninstall rockbox and re install it? or was I supposed to also include the "BL_SD_boardSupportSD.rom" file together with the PP5022.mi4 in that 16MG drive? I doubt it.
Please Help.

WalkGood 10-21-2010 04:21 AM

At this point, you just do either a manual rockbox install or use the rockbox installer.

Sansa-E260RockBoxed 10-29-2010 02:20 AM

Well, in case anybody is still reading this post with these same problems on their sansa E260s, I'll let you know that I finally got my sansa working again and with Rockbox. I'll go ahead and tell you that I am not very computer savvy, but I did some reading on this problem and went ahead and gave it a try since I had nothing to lose.

Man I missed Rockbox so much, as I said on my previous post I got it working, but only with the Sansa OF firmware. To get rockbox to work again (because I knew it was still in the player since all the files were there, it just wouldn't boot to rockbox) I thought it was just the bootloader, so I ran the installer (Rockbox Utility) and uninstalled/reinstalled the bootloader and Voila! Rockbox Lives! :)
It still bothers me that when I go to the OF it almost always wants to do a refreshing of the player and takes forever, but that doesn't happen when it's in Rockbox OF.
Oh, it now works on both MSC and MTP Usb modes since before the bootloader reinstallation.

You can find the .mi4 that i mentioned on the previous post here: http://kb.sandisk.com/app/answers/de...%3D/sno/0#e200 if the link is down just go to sandisk.com, click on support, than "other mp3's/legacy players" and choose your appropriate player. I extracted it and just copied that .mi4 file and pasted it on the recovery mode 16mg drive to get it to refresh.

Lesson Learned: I will never hook it up to the xbox360 again and I advise you do the same. Just in case!
I will try to remember to update you at a later time (hopefully a long, long time) of how it turned out.

WalkGood 10-29-2010 04:21 AM

Congrats, great to hear all is fine ...

herefornow 10-30-2010 05:12 AM

Thanks for coming back with all your info. May be helpful some day.


All times are GMT -5. The time now is 10:49 AM.