abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Samsung (http://www.anythingbutipod.com/forum/forumdisplay.php?f=5)
-   -   YH-J70 - replacing HDD with CF (http://www.anythingbutipod.com/forum/showthread.php?t=56985)

tmcdos 08-18-2010 03:22 AM

YH-J70 - replacing HDD with CF
 
Hi.

I read in forums that people are successfully changing HDDs in Creative Zen and Apple iPod, so I decided to give it a try and replace HDD in my Samsung YH-J70 with a compact flash card.
But with no success - the player comes to the message "System Loading ..." and then hangs, the only way to stop is to remove the battery.
Does anyone have any clues or ideas ?

Thanks.

lebellium 08-18-2010 06:36 AM

No one tried that before AFAIK so you're like a guinea-pig^^
Could you precise the steps - what you did exactly?

dfkt 08-18-2010 06:41 AM

FWIW, both the Cowon X5 and iriver H100/300 only accept CF cards as storage when Rockbox is used - CF cards won't work with their stock firmwares. Even if it's possible with some players, like the iPod Mini, to replace HDDs with solid state, some others don't like it much.

tmcdos 08-18-2010 07:40 AM

Okay, here is what I did:
1. Connect the player to my PC through the USB port
2. Copied ALL files and folders from it to my PC
3. Connect my card reader to the PC
4. Connect a Kingston 512MB compact flash
5. Copid all files and folders from PC to the CF card (MUSIC, PHOTO, TEXT, SYS, SYSTEM ....)
6. Opened the case (2 screws)
7. Removed the Hitachi HDD
8. Put the CF card with its label sitting on top (i.e. to me, not to the player internals). I am pretty sure pin 1 on the CF card mathes pin 1 on the player connector.
9. Powered on the player
10. Player shows the blue animation with SAMSUNG ad
11. Player shows the message "System Loading ..."
12. Player hangs

I also tried with a 4GB SanDisk Extreme 4.0 and also formatting the flash cards with PE-to-USB (with and without rewriting MBR).

I do not possess enough information about the stuff, I just though that if compact flash cards use the IDE interface, it should simply plug-and-play without any effort. Or may be the firmware checks the size of HDD, or there is something wrong with the DRIVE_IDENTIFY results ?
Perhaps I should sell the player and try Yampp or something similar :-)

dfkt 08-18-2010 07:46 AM

Maybe there's a hidden partition on the HDD that holds part of the firmware? That would be easy to find out under Linux, not sure about Windows.

tmcdos 08-18-2010 10:21 AM

PTEDIT32 shows only one partition with these attributes:
1. Type = 0x0C (FAT32 LBA)
2. Bootable = 0 (No)
3. Start cylinder = 0
4. Start head = 1
5. Start sector = 1
6. End cylinder = 1023
7. End head = 254
8. End sector = 63
9. Sectors before = 63
10. Total sectors = 58588992 (27.9 GB)

So your suggestion seems not to be the case ...


All times are GMT -5. The time now is 11:34 PM.