abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Cowon D2/D2+ (http://www.anythingbutipod.com/forum/forumdisplay.php?f=86)
-   -   Cowon D2+ doesn't play any FLAC files! [SOLVED] (http://www.anythingbutipod.com/forum/showthread.php?t=55252)

ahmetcan44 05-23-2010 11:00 AM

Cowon D2+ doesn't play any FLAC files! [SOLVED]
 
Hello everyone,

I've recently bought a D2 and put the latest D2+ FW (3.13) on it. Everything works OK but FLAC files don't. I tried to clean ID3V2 tags with MP3Tag program. But no way... Also FLACs are ripped with libflac 1.2.1 they have 44100 KHz value.

I looked for every solution on iAudiophile and abi forums but still couldn't reach a a solution. What the hell is this machine's problem? It doesn't play a simple FLAC file!

I noticed a few posts related with MTP mode or something like that but I don't what it is and how to deal with it. I drag and drop the files with Windows Explorer. Do I need to use a specific program to drag and drop the files into the player?

I'm using Windows 7 Ultimate x86.

SOLUTION: I CHANGED THE SUFFIX OF FLAC FILES FROM ".flac" TO ".fla" AND THEY ARE WORKING NOW!

ultrauber 05-23-2010 11:25 AM

Yes, it could be that your player is in mtp mode rather than msc. I don't own the d2, so I don't know how this setting is changed, but look around in your settings to find usb mode or similar and change that to msc. (you'll want to empty the player before doing this, and then after the change refill)

Good luck!

Xinz 05-23-2010 08:16 PM

Try use cowon media center and convert, I am guessing the D2+ doesn't read the libflac tag well. I've come across a few flacs that doesn't play and I just reconvert them to flac using cowon media center

ahmetcan44 05-25-2010 07:38 AM

I don't have any hope but I'm gonna look for MTP-MSC mode in player when I get back to home.

Gonna inform you about the results.

Thank you.

ahmetcan44 05-29-2010 01:46 PM

Guys, hello again with bad news.

It still doesn't play FLAC files. There is no option related with MTP-MSC modes. Please, any solution? I've sent an e-mail to COWON. Waitin' for a reply...

Xinz 05-30-2010 03:45 AM

u tried my method?
You can send me one of your flac file to test
I think I'll drop u a PM

ahmetcan44 06-06-2010 06:54 PM

I got the Rockbox FW 3.13 and everthing works OK.

By the way, I should say that the Rockbox is the best solution for this device! It has everything that a user may need :)

Xinz 06-06-2010 07:27 PM

Good to hear that, I didn't use rockbox so couldn't advise on that

dotchoo 09-15-2010 02:05 AM

Thanks
 
Quote:

Originally Posted by Xinz (Post 473284)
Try use cowon media center and convert, I am guessing the D2+ doesn't read the libflac tag well. I've come across a few flacs that doesn't play and I just reconvert them to flac using cowon media center

wow Xinz, thanks so much for this solution, i thought my E2 was broken, whenever it tried to play a flac it would go into "total shutdown" (it would turn off and never turn back on or be recognized by the computer unless i pressed the reset button for 5 secs). fixed it with conversion from flac to ...flac in cowon media center. :D

Xinz 09-15-2010 03:19 AM

Woah, I've never encountered shutdown. Normally those with problems will not play and stop there.

JTSDesigns 11-15-2010 06:18 PM

I had a problem with my D2+ locking up on random flac files. When I looked into it further, I discovered that ANY information in the tag that was not the bare basic was causing the player to reject the file and lockup. It took me days to cleanse my collection-but once cleansed, everything worked ok. My other player (an upgraded D2) seems to have no problems.

Good luck.

ahmetcan44 04-11-2011 05:17 PM

Hello everyone,

I removed Rockbox after a while because it is an unfinished work. So buggy.

My player doesn't play FLAC files. Any ideas? FW is 2.59 and I tried MTP-MSC modes. No way. I cleaned all the tags on FLAC files but no, no and no; it doesn't play FLAC files. I drag and drop files to the player but nothing is shown up.

michael2508 04-17-2011 01:53 PM

Try to play the file FLAC CD quality test from http://www.linnrecords.com/linn-down...testfiles.aspx. :)

ahmetcan44 04-30-2011 04:39 PM

I solved the problem with the help of a friend from iAudiophile and added the solution to first post :)


All times are GMT -5. The time now is 03:47 AM.