abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sony Walkman (http://www.anythingbutipod.com/forum/forumdisplay.php?f=90)
-   -   Release Year music sort (http://www.anythingbutipod.com/forum/showthread.php?t=37386)

canthavetoomanytoys 12-10-2008 05:17 PM

Release Year music sort
 
Most of my music is ripped to mp4 - no problem. I am having a problem with the mp3 music files in that the year is not being recognized by my Walkman (NWZA818). When I try to sort by "Release Year" the year shows as unknown. Does anyone know what field the Walkman programming is looking at?

Since mp3 has many tag flavors it has been difficult to pinpoint which fields and which standard - ID3v1, ID3v2.3, ID3v2.4 - then UTF-8, UTF-16, ISO, or ANSI.

If I knew what the Walkman is looking for I would have a better starting point.

Thank, Kevin

canthavetoomanytoys 12-11-2008 11:22 PM

I finally gave up trying to get the Walkman to use the mp3 tags. I researched ID3v1 and ID3v2. The ID3v2.3 standard allows the following frames (fields):
TDAT [#TDAT Date]
TORY [#TORY Original release year]
TYER [#TYER Year]

I suspected that Sony uses the "release year" (TORY) data since this is the heading in the player. Most mp3 editors work on the TDAT Date instead. :(

Even though my mp3 tags contained the data and present as v1&2, the Walkman programing is ignorant! :eek:

To prove my contention I converted all my files to m4a using the Nero encoder. The Walkman immediately read the year mp4 tags in the new container even though the data was not altered. Case closed.

Incidentally, I also researched the contention that the file transfer protocol was at fault. I found nothing to verify the theory that MTP is the cause of the tag-year matter. I never tried MSC but have been performing drag & drop transfers with all of my mp4 files without any problem. If anyone has a logical reason I would glad to be corrected.

I hope someone finds this helpful.

matt_t 12-03-2010 07:54 PM

Anyone found the answer to this mp3 Release Year problem? Thx.

CDMP3PlayerFan 12-04-2010 03:32 PM

Quote:

Originally Posted by matt_t (Post 519054)
Anyone found the answer to this mp3 Release Year problem? Thx.

I have had the problem too with my MP3 files when I drag-and-drop the files on to my player (a Sony NWZ-A818) using Windows Explorer. Even though the year information is there in the ID3 tag on the player, it shows up as "Unknown." I also had this problem when using MediaGo (music management software) to load music on my player. Added: I just updated to the latest version of MediaGo and it appears this problem has been resolved. I loaded some songs on my player with the new version of MediaGo and the date appeared on my player.

The only way I was able to get the date to show is to use some form of music management software to load music on my player. Music loaded via MediaMonkey (which I use) and Windows Media Player will show the year on the player.

There is one program that you can try that will allow you to drag and drop files on your player, Content Transfer. It's available as a free program on the Sony website.

It allows you to load songs on your player by dragging and dropping them into the Content Transfer window and they will be loaded on your player with the date appearing. It will also allow you to drag-and-drop songs and playlists from iTunes on your player.

I hope this helps.


All times are GMT -5. The time now is 11:09 AM.