abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa e200 General (http://www.anythingbutipod.com/forum/forumdisplay.php?f=79)
-   -   e250r with "load main image failed" recovery mode fw update dosent help (http://www.anythingbutipod.com/forum/showthread.php?t=28688)

baseeight 04-14-2008 10:54 PM

e250r with "load main image failed" recovery mode fw update dosent help
 
My dad recently bought a Sansa e250r. Right now it gives an error "load main image failed switch to recovery mode" I called technical support and followed there instructions. They had me re-format it by going into recovery mode and copying over the "sansa.fmt" file which didn't help. After that they sent me instructions on how to re flash the FW in recovery mode which i have done several times, both with and without the "sansa.fmt" file.
I was wondering what my next step should be and wanted to make sure I don't further damage it by trying to fix it, most of the information I find is non-R specific or I'm not sure if it is or not. I'm guessing the next step would be to redo the boot loader but I'm not sure if "BL_SD_boardSupportSD.rom" is specific to non-R players.
Thanks in advance for any advice, this seems like a pretty cool device, I might have to look into one for myself if I get this one fixed.

advcomp2019 04-14-2008 11:04 PM

Do you have the version.txt file from recovery mode? I wonder if you have a plain e200.

baseeight 04-14-2008 11:31 PM

i do have the version.txt what should i look for in it? It says on the back of the player it is a rhapsody and also has the model as "e250r"

Note: it is a refurb

advcomp2019 04-14-2008 11:38 PM

The backs can be change easy. So do not worry about the backs. You can past the version.txt on here and I will tell you.

baseeight 04-15-2008 12:26 AM

1 Attachment(s)
Here it is.. thanks

Edit: hmm.. i compared the version.txt to one i found in another post from a different e250r and they are identical.. i guess i do have a rhapsody player.. if anyone has some suggestions im still working on it.

dallinski 04-18-2008 06:08 PM

I also have a e250R and seem to have a corrupt VERSION.TXT. I downloaded your file and wrote over my corrupt VERSION.TXT, but it won't flash (I think). Whenever I eject the player, it just says
"Safe to Disconnect USB
Exit USB2.0 MSD mode"
but it doesn't seem to write the new VERSION.TXT. When I plug it in after, it still has the corrupt VERSION.TXT.

advcomp2019 04-18-2008 06:26 PM

Baseeight, you do have a e200R. Are you sure you are using the e200R firmware?

Dallinski, you sure you had a e200R. Have you tried the e200 version.txt file?

dallinski 04-18-2008 07:56 PM

I haven't tried the e200 VERSION.TXT, but I'm pretty sure that wouldn't make a difference at this point. It seems that I can't get anything to write onto the 16 MB partition. Normally doesn't it automatically write the files once you eject the player?

advcomp2019 04-18-2008 08:18 PM

You can delete that bad one and drag and drop the new back on.

dallinski 04-18-2008 09:15 PM

That is what I have been doing. Once I do that, I eject my player and then plug it back in, but it doesn't have what I saved onto it anymore. It still has the corrupt version.
I also tried to just erase the corrupt .txt file and leave the 16 MB partition empty, but the corrupt .txt was back on my player when I plugged it back in.

advcomp2019 04-18-2008 10:26 PM

You might have to use the e200tool in Linux to recover your Sansa since replacing the txt file does not work.

dallinski 04-21-2008 01:42 AM

Ok, so I've been figuring out how to use e200tool, and I feel pretty comfortable with it now. I restored the bootloader, but I still have the corrupt VERSION.TXT. So, I checked out the commands for e200tool and noticed the "write" command. Can I write the VERSION.TXT through e200tool in manufacturing mode? If so, what is the address?

advcomp2019 04-21-2008 02:28 AM

Dallinski, I think this will help you, then: http://www.anythingbutipod.com/forum...ad.php?t=22253.

baseeight 04-23-2008 05:18 PM

I have been using the e200r FW, the filename is pp5022.mi4 I've also now tryed to redo the bootloader by putting the fw file, sansa.fmt, and BL_SD_boardSupportSD.btl on the device in recovery mode. I still haven't had any luck with it, I'm looking into e200tool at the moment, I'm guessing thats what I'm going to have to do.

fwees 05-05-2008 01:34 PM

I am having the same problem as Dallinski with corrupt VERSION.TXT file. I used the e200tool under Linux and could not get it to correct the file. I tried to overwrite it but still had bad file. I tried all the steps in the beginners step by step to un-brick the e200r with no luck. It goes through all writes but does not complete when disconnected from USB port. Any help would be greatly appreciated.

Rcholla@adelphia.net 05-07-2008 11:37 AM

yea
 
how will use this for the sansa rhapsody

fwees 07-11-2008 05:43 PM

I have a working e260r that I copied the Version.txt file from. Still haven't found a solution to this problem. I think it is truly bricked forever.

advcomp2019 07-11-2008 07:04 PM

Fwees, what does the Version.txt say? Are you sure it is an e260R?

fwees 10-16-2008 08:09 AM

My version.txt was corrupted due to formating. I finally got it fixed by using the procedure submitted by virtuoso015. I dumped the nand info from a working e260r and wrote it to my failing e260r using e2tplus. The thread is now on the e200 FAQ.


All times are GMT -5. The time now is 11:28 PM.