abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa e200 Firmware (http://www.anythingbutipod.com/forum/forumdisplay.php?f=51)
-   -   Deleted boot files in recovery mode, how do I fix?!? (http://www.anythingbutipod.com/forum/showthread.php?t=26569)

smug 02-22-2008 12:29 AM

Deleted boot files in recovery mode, how do I fix?!?
 
My sansa e200 started to restart by itself, so I found out how to get in the recovery mode, but I made the mistake of formatting the player in recovery mode, and I deleted all of the boot files. How do I go about finding those files and making my player work again? Right now, when I start it up it just freezes at the sandisk startup screen?

advcomp2019 02-22-2008 01:15 AM

Does recovery mode still work? If not, you will need to use the e200tool in Linux. The reason why I said Linux because the e200tool in Windows still in a way buggy.

smug 02-22-2008 10:21 AM

Yes, I can get into recovery mode still. What do I do to fix this problem?

Cruleworld 02-22-2008 10:24 AM

Flash your player with the firmware files.

smug 02-22-2008 11:08 AM

My sansa won't flash itself anymore. I put a copy of the firmware into the 16Mb FAT and I safely remove my hardware, and all the player says is "USB 2.0 disconnected" It won't install the firmware.

Cruleworld 02-22-2008 11:34 AM

What firmware version did have on your player before? Try naming the file firmware.mi4

advcomp2019 02-22-2008 02:48 PM

Do you have a version.txt? If so, can you post it that? That will help too.

smug 02-22-2008 03:47 PM

no, you guys don't understand. I have a working version of the firmware. I deleted the boot files so when I turn my sansa on, it just sits at the Sandisk screen. When I reload the firmware and remove hardware safely from my computer, all my sansa says is "Safe to disconnect USB" It won't load that firmware. I'm pretty sure I deleted the boot files: the sansa.fmt, the firmware, and the BL_SDboardSupportSD.rom I tried putting those files back on my computer, but that doesn't work either. Will someone please help me already?!?!?

advcomp2019 02-22-2008 04:31 PM

BL_SDboardSupportSD.rom is the bootloader that will let the Sansa firmware boot up unless you are using a corrupted firmware or bootloader. Sometimes it might take more then one time.

smug 02-22-2008 04:52 PM

So do I need to add the bootloader and the firmware at the same time?

Cruleworld 02-22-2008 04:58 PM

correct

smug 02-22-2008 05:22 PM

I can get into recovery mode just fine every time. I put a copy of the firmware and the .rom bootloader into the 16Mb drive that I get when I use recovery mode. I go to my task bar and remove hardware safely. All my sansa says is "Safe to disconnect USB. Eixt USB 2.0 MSD mode" It doesn't load anything. That's the problem. It won't take any files I put in it. Now what?

advcomp2019 02-22-2008 05:58 PM

Could you try post this info: http://www.anythingbutipod.com/forum...14&postcount=7 ?

smug 02-23-2008 12:08 AM

no, there is no version. I looked at the .txt and all it says is "yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy"

advcomp2019 02-23-2008 12:51 AM

1 Attachment(s)
You need a new version.txt file then. Here is one in the attachments. You need to put it into recovery mode like before.

smug 02-23-2008 08:31 PM

I can't put the new .txt file in the player. My player won't let me write anything to it. It's really corrupted.

advcomp2019 02-24-2008 01:34 AM

Most likely you will need to use the e200tool in Linux, then.

smug 02-24-2008 03:04 PM

I did use the e200 tool for linux. It still won't accept the files.

smug 02-24-2008 11:11 PM

I can access the recovery mode just fine. Recovery mode won't accept any file I put into it, that's my problem. I don't know if there is any way to fix this or if I have to send it in

advcomp2019 02-24-2008 11:20 PM

Have you tried a different computer?


All times are GMT -5. The time now is 12:16 AM.