abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa e200 General (http://www.anythingbutipod.com/forum/forumdisplay.php?f=79)
-   -   e260 formatted from computer while in recovery mode (http://www.anythingbutipod.com/forum/showthread.php?t=23729)

jackassjim 12-23-2007 10:22 AM

e260 formatted from computer while in recovery mode
 
Hi everyone,

Sorry to bother, but I read a lot of threads advising NOT to do that, but no definitive answer on if the device can possibly be salvaged.

So yes, it did happen "inadvertedly"...

Now, I get the "Load main image failed, switch to recovery mode"
I am able to boot into recovery mode.

However, the VERSION.txt that appears on the 16mb disk appears corrupted. I believe that this is (one of) the reason (s) why the Ulitmate Fix fails. When running the .exe used to downgrade the firmware, I get an error message saying that the Version details could not be identified correctly.

I have also tried placing the .mi4 file on the recovery disk, with or without a blank sansa.fmt file, but had no success.

The sandisk tech support only suggests I do the same steps that I already did. Unfortunately, the warranty is not valid anymore.

So, are my options through?

Thanks very much for your time. I appreciate it!

Jim

Slaughter 12-23-2007 11:44 AM

RCM posted a non corrupt version of the version.txt in the firmware forum. Overwrite yours with this one, then try updating your firmware.

jackassjim 12-23-2007 06:14 PM

Hi Slaughter,

Thanks for your reply.

1- I downloaded the VERSION.txt from posted by RCM in this thread: http://www.anythingbutipod.com/forum...ad.php?t=19454

2- Booted the e260 in recovery mode and mounted the 16mb partition.

3- Copied the three files in place.

Code:

hotnuts@mybanana:~/Desktop$ sudo cp VERSION.TXT /media/disk/
hotnuts@mybanana:~/Desktop$ sudo cp PP5022.mi4 /media/disk/
hotnuts@mybanana:~/Desktop$ sudo touch /media/disk/sansa.fmt

4- Pushed lock button to the left and held the power button until the device shutdown.

5- Booted in normal mode but got the same error: "Load main image failed. Switch to Recovery mode"

Note: I also tried all of the above without root permission.

Is there anything obviously wrong with the procedure I followed?

Thanks again!

advcomp2019 12-23-2007 06:46 PM

Do you have an e200R?

jackassjim 12-23-2007 07:29 PM

I do not believe it is a rhapsody. However, I have no box or manual to confirm this. I will search the forum to see how I can make sure it isn't.

cpchan 12-23-2007 07:46 PM

Quote:

Originally Posted by jackassjim (Post 195765)
Code:

hotnuts@mybanana:~/Desktop$ sudo cp PP5022.mi4 /media/disk/

Rename PP5022.mi4 to firmware.mi4. As of version 1.03 of the firmware, Sandisk have changed the name.

Charles

jackassjim 12-23-2007 08:25 PM

Unfortunately, renaming the file does not work either.

I find no indication that this is a rhapsody player. On the back it says e260, not e260r. Also, when I boot into recovery mode, the device gets recognized as a e250. I guess that's normal. But it is really the 4gb version.

I am really close to quitting now. Too bad, it really looked like a neat player. I wish I hadn't been so ambitious and tried to install rockbox... :(

cpchan 12-23-2007 08:48 PM

Quote:

Originally Posted by jackassjim (Post 195802)
Unfortunately, renaming the file does not work either.

Try some of the suggestions here:

http://www.rockbox.org/twiki/bin/vie...nsaE200Unbrick

Charles

jackassjim 12-23-2007 09:27 PM

I had come across that link already. The section about manufacturing mode only applies for situations in which the recovery mode cannot be accessed. The i2c rom doesn't appear to be corrupted since I do not get into pre-boot mode. The reformat doesn't help (see my post above).

I cannot boot into the original firmware by holding the |<< key and starting the device.

And the other suggestion is to drag the firmware onto the 16mb disk. Been there, done that...

ARGH! This is so frustrating!

ps: it's really great to see how much doc was put together by the community though...

cpchan 12-23-2007 09:41 PM

Quote:

Originally Posted by jackassjim (Post 195817)
I had come across that link already.

I suggest you get an account and ask on rockbox.org, since most of the devs hangs out there. I can't really help you any further since I really have no experience with "Recovery" and other modes. I have been using Rockbox since the start of the port with no problems and I never had to use any of them.

FWIW, if you want and if you allow me ssh access to you machine, I might be able to take a look at it.

Charles

jackassjim 12-23-2007 10:42 PM

I will definitely open an account on the rockbox website.

I really appreciate your offer. This is the first time I attempt to setup a ssh server, and I'm not sure if my port forward on the router will work, but let's give it a try.

I will pm you adress and username and password plus the irc channel where you can meet me. I'll be there for the next few hours.

Thanks A LOT!!!!

dalio 10-10-2008 07:52 PM

hi i have exactly the same problem as jackassjim and i am utterly frusterated.
was there a fix that worked i have also tried everyhitng that he has tried.
help please.

advcomp2019 10-10-2008 09:27 PM

Please, dalio, try not to post in old threads. The thread that I am helping you in is just fine.


All times are GMT -5. The time now is 11:19 AM.