abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Clip / Clip+ / Clip Zip Rockbox (http://www.anythingbutipod.com/forum/forumdisplay.php?f=228)
-   -   Rockbox: Clip v1 (http://www.anythingbutipod.com/forum/showthread.php?t=36978)

kredig 05-25-2009 09:50 AM

i think the rockbox doesn't like vbr (exactaudiocopy + lame 3.98.2 and tagged with mp3tag or mediamonkey) at all. it totally crashes after that (at first it says that the codec is wrong and then the player doesn't recognizes the rockbox firmware)
i am keeping the sansa firmware until there will be a public release i guess :mad:

WalkGood 05-25-2009 11:27 AM

Quote:

Originally Posted by BXCracer (Post 359376)
I mean I am having same stops and freezes as lot of other testers. It looks like one of the main developer is having them too. But you don't :D weird... What format of music are you usually listening to ? Maybe some special tagging or something ?

Quote:

Originally Posted by WalkGood (Post 359378)
oh, my confusion since you quoted me. On older stuff I have 192 vbr, tagged in mp3tag. I'll try some other rips today and post back later.

Ok, I tested 4 different rips below, rockbox has - repeat off, folder advance off and browsing by db:
  • FLAC - play back was very good & clean, playback stopped twice, once my fault for fiddling on settings and the second time on its own, but this was a first - it rebooted the clip, a simple resume started playback again.
  • -V 2 - vbr-new - No issues for whole album, although I didnít fiddle around at all, playback was also very good & clean
  • vbr 192 MM, mp3tag - No issues for a whole album, no fiddling, playback was also very good & clean
  • 192 kbps FhG - No issues for a whole album, no fiddling, playback was also very good & clean

We were talking in irc earlier and later Iím going to try
Quote:

[08:51] <dfkt> use file/folder browsing, repeat off, folder advance on, and just let a few albums play
[08:52] <WalkGood_> i'll try your method out once done with this and let you know
[08:52] <dfkt> cool, that should be interesting
Guess Iíll report back later, /me is off to swim :p

Mikerman 05-25-2009 12:43 PM

Quote:

Originally Posted by dfkt (Post 359353)
Funman mentioned that the ability to play DRMed files will be lost forever once you flash a Rockbox bootloader on the Clip. You asked this question a few pages ago and already got a definite answer: http://anythingbutipod.com/forum/sho...&postcount=189

Thanks. I had gone back to the Rockbox Clip, etc. port development thread and the issue seemed open, for future exploration. And so I just thought to ask the users here, in case someone had actually checked this out.

kilrogg 05-25-2009 03:14 PM

First of all, great thanks to the Rockbox team! The firmware works, and gapless is awesome! :)

But I guess I've found a bug. When I pause a track and then switch to another one, playback continues for 30 seconds and then stops so I have to reboot the player.
I don't know if it depends on the codec but I use aoTuV Ogg Vorbis beta 5.5 codec most of the time, and I didn't test it on mp3s or FLACs. Should I?..

WalkGood 05-25-2009 03:17 PM

Tried file/folder browsing, repeat off, folder advance on, and just let a few albums play. 2 freezeís on 1st track of albums :/ so I switched back Ö

WalkGood 05-25-2009 03:21 PM

Quote:

Originally Posted by kilrogg (Post 359489)
First of all, great thanks to the Rockbox team! The firmware works, and gapless is awesome! :)

But I guess I've found a bug. When I pause a track and then switch to another one, playback continues for 30 seconds and then stops so I have to reboot the player.
I don't know if it depends on the codec but I use aoTuV Ogg Vorbis beta 5.5 codec most of the time, and I didn't test it on mp3s or FLACs. Should I?..

Pause and switch works fine on my mp3's.

danieljeronimo 05-25-2009 06:02 PM

Hi everybody

I've been waiting a long time for the clip port, more or less since I purchased my very own silver 4g v1 clip 6 months ago. Well, I have tried to install the bootloader gently made available by one of the members of this forum, but no luck. It seems unable to play many mp3s (no codec!, it says), it cannot build a database and just panics a lot (and it gave me the thrills). It made the Sansa Firmware unable to build the database, also. Maybe I don't know enough about how to installl it and make it run and that's all.
Anyway, I had to format the little thingy. Just have to wait a couple months more (I expect I'm being pessimist here) for an official release. The sound, when it sounded, was great (I really can`t complain). The radio worked without problem.
Just to let you know, if anybody has had the same problem. And to thank the members of this forum, that have discussed all this in depth and gave me the courage to give it a try.

pros1n 05-25-2009 06:32 PM

I bet that when people see that there is a release of rockbox on the clip, 75-80% of the people will download and 60% of the people who downloads it will want to gamble with their clips to try to get 1. So here's the moral, don't think that what you see is what you get.

Well, thanks to WalkGood again, I now have no problem playing music. I just don't fiddle around with my clip like changing the songs constantly and etc. Just let it be. :p

Mikerman 05-25-2009 07:21 PM

If you're talking about the Clip port code that is around now, please be careful with terminology: there is no release of Rockbox for the Clip yet. What people have been installing is a development version that is being worked on daily to get to, hopefully, a release version. Hence the warnings every which way, that one's player could be adversely affected (i.e. bricked).

Kiva 05-28-2009 03:22 PM

I cant wait til this port is complete. This will be my first chance to use Rockbox, and i've heard so many good things about it. Gonna wait til its complete, instead of using the beta, though.

dfkt 05-28-2009 05:23 PM

You can always get the newest official Rockbox builds from here: http://build.rockbox.org/dist/build-clip/rockbox.zip

This is just so people use the official builds instead of unverified 3rd party builds.

boreas 05-28-2009 06:43 PM

hey guys,
a couple of days ago i tried rockboxing my clip but without luck i couldnt have and got back to the OF.Today i ve noticed that when i pause a track the clip shuts itself off and i have to turn it on again.i had the latest firm before my rockbox attempt but it used to stay on pause.i dont know why it does that now though i cant complain cause i used to forget it on pause and the battery used to die because of that.anyone knows why???

Alohamora 05-28-2009 08:00 PM

Quote:

Originally Posted by boreas (Post 360685)
hey guys,
a couple of days ago i tried rockboxing my clip but without luck i couldnt have and got back to the OF.Today i ve noticed that when i pause a track the clip shuts itself off and i have to turn it on again.i had the latest firm before my rockbox attempt but it used to stay on pause.i dont know why it does that now though i cant complain cause i used to forget it on pause and the battery used to die because of that.anyone knows why???

Check under Settings -> Power -> Auto Power, that's how long it will stay on before it shuts off when not playing. You may have turned the setting off before.

boreas 05-29-2009 06:21 AM

oh silly me:pthank you;):D

Mikerman 05-29-2009 11:39 AM

Quote:

Originally Posted by dfkt (Post 360640)
You can always get the newest official Rockbox builds from here: http://build.rockbox.org/dist/build-clip/rockbox.zip

This is just so people use the official builds instead of unverified 3rd party builds.

Thanks for the link, dfkt. I guess it's the newest official Rockbox alpha developmental build. ;)

saratoga 05-29-2009 11:50 AM

Its not an alpha build or anything like that. Its just an automatic build of whats in SVN. We've actually been doing then on every SVN update for the Clip for the last 6 months in order to ensure that the SVN code compiles fine.

Mikerman 05-30-2009 03:50 AM

Yep, I understand--was just trying to emphasize that a release version has not yet issued and that this is a port still in development.

saratoga 06-02-2009 08:54 PM

http://www.duke.edu/~mgg6/rockbox/rockbox-clip.zip

SVN checkout from this morning with tonight's latest version of FS#10048 applied. My clip has been playing for about half an hour without issue. Battery life should be significantly improved over SVN due to greatly increased CPU performance.

dfkt 06-02-2009 08:59 PM

I love how I can type "FS#10048" into Google and get the Rockbox Flyspray page as first result... thanks for the build Saratoga.

EDIT: getting the same audio lockups as before.

saratoga 06-02-2009 09:54 PM

Mine locked up too, but it seemed to take a lot longer (maybe once per album instead of once per song). Getting closer I suppose.


All times are GMT -5. The time now is 04:58 AM.